summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/frescobaldi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/frescobaldi')
-rw-r--r--media-sound/frescobaldi/Manifest2
-rw-r--r--media-sound/frescobaldi/frescobaldi-2.0.16.ebuild35
-rw-r--r--media-sound/frescobaldi/frescobaldi-2.18.ebuild41
-rw-r--r--media-sound/frescobaldi/metadata.xml12
4 files changed, 90 insertions, 0 deletions
diff --git a/media-sound/frescobaldi/Manifest b/media-sound/frescobaldi/Manifest
new file mode 100644
index 000000000000..76efcc818112
--- /dev/null
+++ b/media-sound/frescobaldi/Manifest
@@ -0,0 +1,2 @@
+DIST frescobaldi-2.0.16.tar.gz 3861027 SHA256 d8e89a662da45ae6c514365a4eb6895419f8058014f5393041988a55f05eea8a SHA512 7f04b84ec73ee84094ef8c11ef546a111b3c795dff9611a0627180b6509103c7505e5799a3ad0dd8d4d54dca2596f34835dca0018f78fe55966665c5eb14f3ab WHIRLPOOL 3c1d2f9d79ab04536664176d834014d5daab73d115961913b40c247dfe142cbf95761e44043ccfd914dc6cf64eb307d29fba0cb128afd44c3c345e1cb6edcd9a
+DIST frescobaldi-2.18.tar.gz 4075233 SHA256 6531a6425a0b0a471fb0845098e9c890e59d6379636ed79b4512a48599327d4b SHA512 31c0f3d96e26f2b2a8383b25f56e89493f115bc7a60478a05be8c6f8e7f9189592ea106a366c999293e96c7860811cfe7505906f8f625a54c3ad58a9a428700a WHIRLPOOL de89589068258a421491b312f4928ed787921bf4b1f982ed31bd881f9ed59b7990cc2f2ccfb47a9cd054a19d545ae31a746dcb000267f37701a1552517be59a1
diff --git a/media-sound/frescobaldi/frescobaldi-2.0.16.ebuild b/media-sound/frescobaldi/frescobaldi-2.0.16.ebuild
new file mode 100644
index 000000000000..69072b1ad8f6
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-2.0.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="http://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain" # public-domain is for bundled Tango icons
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portmidi"
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2
+ portmidi? ( media-libs/portmidi )"
+DEPEND="${RDEPEND}"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/frescobaldi/frescobaldi-2.18.ebuild b/media-sound/frescobaldi/frescobaldi-2.18.ebuild
new file mode 100644
index 000000000000..819e32119157
--- /dev/null
+++ b/media-sound/frescobaldi/frescobaldi-2.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 gnome2-utils
+
+DESCRIPTION="A LilyPond sheet music text editor"
+HOMEPAGE="http://www.frescobaldi.org/"
+SRC_URI="https://github.com/wbsoft/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 public-domain" # public-domain is for bundled Tango icons
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portmidi"
+
+RDEPEND="dev-python/python-poppler-qt4[${PYTHON_USEDEP}]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ >=media-sound/lilypond-2.14.2
+ portmidi? ( $(python_gen_cond_dep 'media-libs/portmidi[${PYTHON_USEDEP}]' python2_7) )"
+DEPEND="${RDEPEND}"
+
+python_prepare_all() {
+ # Instructs install unconditionally for a Windows system
+ rm setup.cfg || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/media-sound/frescobaldi/metadata.xml b/media-sound/frescobaldi/metadata.xml
new file mode 100644
index 000000000000..cf9a3e330f8e
--- /dev/null
+++ b/media-sound/frescobaldi/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <herd>python</herd>
+ <use>
+ <flag name="portmidi">Enable <pkg>media-libs/portmidi</pkg> support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">wbsoft/frescobaldi</remote-id>
+ </upstream>
+</pkgmetadata>