summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-01 11:09:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-01 11:09:06 +0200
commit5ff778254504f917eaa49a68f648e08b9a262391 (patch)
tree753b4c5277a594c2d17baa970229e11edc3cde02 /media-sound/mpg123
parentmedia-plugins/frei0r-plugins: bump to 1.6.0 (diff)
downloadgentoo-5ff778254504f917eaa49a68f648e08b9a262391.tar.gz
gentoo-5ff778254504f917eaa49a68f648e08b9a262391.tar.bz2
gentoo-5ff778254504f917eaa49a68f648e08b9a262391.zip
media-sound/mpg123: bump to 1.25.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-sound/mpg123')
-rw-r--r--media-sound/mpg123/Manifest1
-rw-r--r--media-sound/mpg123/mpg123-1.25.0.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/media-sound/mpg123/Manifest b/media-sound/mpg123/Manifest
index 72d6ee413370..12f3e590ad3f 100644
--- a/media-sound/mpg123/Manifest
+++ b/media-sound/mpg123/Manifest
@@ -1,2 +1,3 @@
DIST mpg123-1.23.8.tar.bz2 893728 SHA256 de2303c8ecb65593e39815c0a2f2f2d91f708c43b85a55fdd1934c82e677cf8e SHA512 7b77b543bd6a127095c6a6a2e7f9b5933f5a391734cc6dcbc160f786008afcd74646a7c304e1be682042221648b0fcae7efafda4bbe66ba30a7021740abddc34 WHIRLPOOL bfc0c8d186f6ea827d4d3cbacf2accbba080798113b31757ad1c3f0aea12ebb94233ee81a7fea493af38bdbf59407add73976933d749229e83371833ba79caa4
DIST mpg123-1.24.0.tar.bz2 912049 SHA256 55fb169a7711938f5df0497d1ffe28419fbef50011dc01d00b216379e6a2256c SHA512 e7c0d7a103daf496e75a6aa6aca861cfc0ad391f242335990c2360305e567039d24ca3b37a35f79b75749055e255f4692b8b43d2fec332b119223b00e12b0cb7 WHIRLPOOL 3d1c882c4c2c0cf8fc575be3a65f9c9d61a1549f75abeb983c2bafef3c303507bdc494594060bc732096c3d7fb96c372d2554a698a46a19c1c6e5f48e5e61771
+DIST mpg123-1.25.0.tar.bz2 917205 SHA256 552e3e1db045e00f474252917007795ac295863fc8b13891859b3382d2f24e48 SHA512 fc5047fe88639b1cd5c44cdd054d452984abfbf572d064c7f465b7cef8a03b389591daf4934010f227a28d0e12bf0b0214d0c92132e893af90cd859389558e3c WHIRLPOOL c4fb1c198f29a41d494e1442223532ec65712f6f83bf8eb12ab60fee7a3a61652e0f7be8d42bff747bc1f1d0c0615256238abc98fa9b5812889959ab1a49eef9
diff --git a/media-sound/mpg123/mpg123-1.25.0.ebuild b/media-sound/mpg123/mpg123-1.25.0.ebuild
new file mode 100644
index 000000000000..859664f68814
--- /dev/null
+++ b/media-sound/mpg123/mpg123-1.25.0.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic toolchain-funcs libtool multilib-minimal
+
+DESCRIPTION="a realtime MPEG 1.0/2.0/2.5 audio player for layers 1, 2 and 3"
+HOMEPAGE="http://www.mpg123.org/"
+SRC_URI="http://www.mpg123.org/download/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_3dnow cpu_flags_x86_3dnowext alsa altivec coreaudio int-quality ipv6 jack cpu_flags_x86_mmx nas oss portaudio pulseaudio sdl cpu_flags_x86_sse"
+
+# No MULTILIB_USEDEP here since we only build libmpg123 for non native ABIs.
+RDEPEND="app-eselect/eselect-mpg123
+ dev-libs/libltdl:0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+ nas? ( media-libs/nas )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-sound/pulseaudio )
+ sdl? ( media-libs/libsdl )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-soundlibs-20130224-r9
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS.libmpg123 README )
+
+pkg_setup() {
+ # Build fails without -D_GNU_SOURCE like this:
+ # error: ‘struct hostent’ has no member named ‘h_addr’
+ append-cflags -D_GNU_SOURCE
+}
+
+src_prepare() {
+ default
+ elibtoolize # for Darwin bundles
+}
+
+multilib_src_configure() {
+ local _audio=dummy
+ local _output=dummy
+ local _cpu=generic_fpu
+
+ if $(multilib_is_native_abi) ; then
+ for flag in nas portaudio sdl oss jack alsa pulseaudio coreaudio; do
+ if use ${flag}; then
+ _audio+=" ${flag/pulseaudio/pulse}"
+ _output=${flag/pulseaudio/pulse}
+ fi
+ done
+ fi
+
+ use altivec && _cpu=altivec
+
+ if [[ $(tc-arch) == amd64 || ${ARCH} == x64-* ]]; then
+ use cpu_flags_x86_sse && _cpu=x86-64
+ elif use x86 && gcc-specs-pie ; then
+ # Don't use any mmx, 3dnow, sse and 3dnowext #bug 164504
+ _cpu=generic_fpu
+ elif use x86-macos ; then
+ # ASM doesn't work quite as expected with the Darwin linker
+ _cpu=generic_fpu
+ else
+ use cpu_flags_x86_mmx && _cpu=mmx
+ use cpu_flags_x86_3dnow && _cpu=3dnow
+ use cpu_flags_x86_sse && _cpu=x86
+ use cpu_flags_x86_3dnowext && _cpu=x86
+ fi
+
+ local myconf=""
+ multilib_is_native_abi || myconf="${myconf} --disable-modules"
+
+ ECONF_SOURCE="${S}" econf \
+ --with-optimization=0 \
+ --with-audio="${_audio}" \
+ --with-default-audio=${_output} \
+ --with-cpu=${_cpu} \
+ --enable-network \
+ $(use_enable ipv6) \
+ --enable-int-quality=$(usex int-quality) \
+ ${myconf}
+
+ if ! $(multilib_is_native_abi) ; then
+ sed -i -e 's:src doc:src/libmpg123:' Makefile || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ mv "${ED}"/usr/bin/mpg123{,-mpg123}
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}
+
+pkg_postinst() {
+ eselect mpg123 update ifunset
+}
+
+pkg_postrm() {
+ eselect mpg123 update ifunset
+}