summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/opus-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/opus-tools')
-rw-r--r--media-sound/opus-tools/Manifest3
-rw-r--r--media-sound/opus-tools/metadata.xml5
-rw-r--r--media-sound/opus-tools/opus-tools-0.1.6.ebuild46
-rw-r--r--media-sound/opus-tools/opus-tools-0.1.8.ebuild48
-rw-r--r--media-sound/opus-tools/opus-tools-0.1.9.ebuild46
5 files changed, 148 insertions, 0 deletions
diff --git a/media-sound/opus-tools/Manifest b/media-sound/opus-tools/Manifest
new file mode 100644
index 000000000000..b24160840ccf
--- /dev/null
+++ b/media-sound/opus-tools/Manifest
@@ -0,0 +1,3 @@
+DIST opus-tools-0.1.6.tar.gz 306902 SHA256 cc86dbc2a4d76da7e1ed9afee85448c8f798c465a5412233f178783220f3a2c1 SHA512 547828082c4838643eeda513f65316b60b0e44c4a0826ef39cbfa3fe81df71b30651c03ceee7729aeb74258c259014bf95ca5f01aba097a4de8334e58c8e7ce6 WHIRLPOOL 68be6525aee01454631a3123cfa6891206cd5a5f5dfb413c044d112e2d6d5c506d1d45591951fb936a07f4f5bcc7e788bcfe266a8a566de4216a34b98df20e75
+DIST opus-tools-0.1.8.tar.gz 388711 SHA256 e4e188579ea1c4e4d5066460d4a7214a7eafe3539e9a4466fdc98af41ba4a2f6 SHA512 c36181f073e05d1535f149eb638d58fb14386e1caae23a3e1a7008f5530d033f4c7f388b48f3d8b111a9e55b78f5e91b69e8c96b6c9074700a3b15a1796c0ade WHIRLPOOL 0d2c06265bd108edf5ad4daf6c6e2735daff5172f14c6c445b062e04697adbd0bc4f5cba14482702d3a934f12a336893c04ba590f9e41427018f8111daf0fbfd
+DIST opus-tools-0.1.9.tar.gz 385158 SHA256 b1873dd78c7fbc98cf65d6e10cfddb5c2c03b3af93f922139a2104baedb4643a SHA512 e2cdc0c9c24297565f9d457893bcc548696b1a9c9b66e4cd48ddbe4dcf865bc50da5ed1b438b2b9ecdcd8be1d7c211d2be199f707cdbcd8a46a75353b0173a4c WHIRLPOOL c0acf53763c6263ece4b8b796373ba689006282987043ed15c3d747d08cc9fae76e968a643919b4d9d08a00acc9b8ad46e4fefbdd43263d7293ae2fb93e88278
diff --git a/media-sound/opus-tools/metadata.xml b/media-sound/opus-tools/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-sound/opus-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/opus-tools/opus-tools-0.1.6.ebuild b/media-sound/opus-tools/opus-tools-0.1.6.ebuild
new file mode 100644
index 000000000000..362552f6b72c
--- /dev/null
+++ b/media-sound/opus-tools/opus-tools-0.1.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-2"
+ EGIT_REPO_URI="git://git.opus-codec.org/${PN}.git"
+fi
+
+inherit autotools ${SCM}
+
+DESCRIPTION="The Opus codec is designed for interactive speech and audio
+transmission over the Internet."
+HOMEPAGE="http://opus-codec.org/"
+if [[ ${PV} == *9999 ]] ; then
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libogg-1.3.0
+ >=media-libs/opus-0.9.10"
+DEPEND="virtual/pkgconfig
+ ${DEPEND}"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
+}
diff --git a/media-sound/opus-tools/opus-tools-0.1.8.ebuild b/media-sound/opus-tools/opus-tools-0.1.8.ebuild
new file mode 100644
index 000000000000..37a43410509a
--- /dev/null
+++ b/media-sound/opus-tools/opus-tools-0.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Royalty-free, highly versatile audio codec"
+HOMEPAGE="http://opus-codec.org/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.opus-codec.org/${PN}.git"
+ SRC_URI=""
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac"
+
+RDEPEND=">=media-libs/libogg-1.3.0
+ >=media-libs/opus-1.0.3
+ flac? ( >=media-libs/flac-1.1.3 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with flac)
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-sound/opus-tools/opus-tools-0.1.9.ebuild b/media-sound/opus-tools/opus-tools-0.1.9.ebuild
new file mode 100644
index 000000000000..e3975b1b99ae
--- /dev/null
+++ b/media-sound/opus-tools/opus-tools-0.1.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Royalty-free, highly versatile audio codec"
+HOMEPAGE="http://opus-codec.org/"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.opus-codec.org/${PN}.git"
+elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
+ SRC_URI="http://dev.gentoo.org/~lu_zero/${PN}/${P}.tar.xz"
+else # Official release
+ SRC_URI="http://downloads.xiph.org/releases/opus/${P}.tar.gz"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~x86"
+IUSE="flac"
+
+RDEPEND=">=media-libs/libogg-1.3.0
+ >=media-libs/opus-1.0.3
+ flac? ( >=media-libs/flac-1.1.3 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with flac)
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}