summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-04-27 20:58:09 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-21 01:28:32 +0200
commitce6e2c37f0488256ee7c74462978634b3d16a64c (patch)
treecd7eb8b93214a70dbbc616b2126a9d14a144f17f /media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild
parentmedia-gfx/lximage-qt: add version 0.15.0 (diff)
downloadgentoo-ce6e2c37f0488256ee7c74462978634b3d16a64c.tar.gz
gentoo-ce6e2c37f0488256ee7c74462978634b3d16a64c.tar.bz2
gentoo-ce6e2c37f0488256ee7c74462978634b3d16a64c.zip
media-sound/pavucontrol-qt: add version 0.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild')
-rw-r--r--media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild b/media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild
new file mode 100644
index 000000000000..21b7b2ce6716
--- /dev/null
+++ b/media-sound/pavucontrol-qt/pavucontrol-qt-0.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Qt GUI Pulseaudio Mixer"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.7.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtwidgets:5
+ media-sound/pulseaudio[glib]
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"