summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-04-27 00:55:30 +0300
committerSam James <sam@gentoo.org>2022-04-28 16:59:52 +0100
commitd5453db8eeeee7aec0b61f772a7b76e3400f1d8b (patch)
treec0e4d0d61934e86f8a6e44fcf3e62b02ec6e070a /media-sound/pulseaudio-daemon
parentmedia-libs/libpulse: Client part of split autospawn implementation (diff)
downloadgentoo-d5453db8eeeee7aec0b61f772a7b76e3400f1d8b.tar.gz
gentoo-d5453db8eeeee7aec0b61f772a7b76e3400f1d8b.tar.bz2
gentoo-d5453db8eeeee7aec0b61f772a7b76e3400f1d8b.zip
media-sound/pulseaudio-daemon: Daemon part of split autospawn implementation
Now that libpulse has daemon autospawn disabled, enable it back for systems without systemd when pulseaudio-daemon is installed. Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25207 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/pulseaudio-daemon')
-rw-r--r--media-sound/pulseaudio-daemon/files/enable-autospawn.conf2
-rw-r--r--media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1-r1.ebuild (renamed from media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1.ebuild)6
2 files changed, 8 insertions, 0 deletions
diff --git a/media-sound/pulseaudio-daemon/files/enable-autospawn.conf b/media-sound/pulseaudio-daemon/files/enable-autospawn.conf
new file mode 100644
index 000000000000..5681459a32cd
--- /dev/null
+++ b/media-sound/pulseaudio-daemon/files/enable-autospawn.conf
@@ -0,0 +1,2 @@
+# Enable automatic spawning of pulseaudio daemon
+autospawn = yes
diff --git a/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1.ebuild b/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1-r1.ebuild
index 71655e65efbd..19134e3b2752 100644
--- a/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1.ebuild
+++ b/media-sound/pulseaudio-daemon/pulseaudio-daemon-15.99.1-r1.ebuild
@@ -272,6 +272,12 @@ src_install() {
|| die
fi
+ # Only enable autospawning pulseaudio daemon on systems without systemd
+ if ! use systemd; then
+ insinto /etc/pulse/client.conf.d
+ newins "${FILESDIR}/enable-autospawn.conf" "enable-autospawn.conf"
+ fi
+
find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
}