summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-29 00:16:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-02 19:06:37 +0200
commit80fdc7def4a6fefb711f282435ebc14f10078422 (patch)
treeb85d996da7e0d1d9e5ce0ad0898967273cb87be7 /media-sound/pulseaudio
parentmedia-sound/pulseaudio: Port to Qt5 (diff)
downloadgentoo-80fdc7def4a6fefb711f282435ebc14f10078422.tar.gz
gentoo-80fdc7def4a6fefb711f282435ebc14f10078422.tar.bz2
gentoo-80fdc7def4a6fefb711f282435ebc14f10078422.zip
media-sound/pulseaudio: Fix build with glibc-2.27
Closes: https://bugs.gentoo.org/646566 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'media-sound/pulseaudio')
-rw-r--r--media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch59
-rw-r--r--media-sound/pulseaudio/pulseaudio-11.1-r1.ebuild5
2 files changed, 63 insertions, 1 deletions
diff --git a/media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch b/media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch
new file mode 100644
index 000000000000..a89167b603d0
--- /dev/null
+++ b/media-sound/pulseaudio/files/pulseaudio-11.1-glibc-2.27.patch
@@ -0,0 +1,59 @@
+From: Tanu Kaskinen <tanuk@iki.fi>
+Date: Wed, 24 Jan 2018 03:51:49 +0200
+Subject: memfd-wrappers: only define memfd_create() if not already defined
+
+glibc 2.27 is to be released soon, and it will provide memfd_create().
+If glibc provides the function, we must not define it ourselves,
+otherwise building fails due to conflict between the two implementations
+of the same function.
+
+BugLink: https://bugs.freedesktop.org/show_bug.cgi?id=104733
+(cherry picked from commit dfb0460fb4743aec047cdf755a660a9ac2d0f3fb)
+---
+ configure.ac | 3 +++
+ src/pulsecore/memfd-wrappers.h | 7 ++++---
+ 2 files changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 77b5ff5..3a71fd8 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -607,6 +607,9 @@ AS_IF([test "x$enable_memfd" = "xyes" && test "x$HAVE_MEMFD" = "x0"],
+ [AC_MSG_ERROR([*** Your Linux kernel does not support memfd shared memory.
+ *** Use linux v3.17 or higher for such a feature.])])
+
++AS_IF([test "x$HAVE_MEMFD" = "x1"],
++ AC_CHECK_FUNCS([memfd_create]))
++
+ AC_SUBST(HAVE_MEMFD)
+ AM_CONDITIONAL([HAVE_MEMFD], [test "x$HAVE_MEMFD" = x1])
+ AS_IF([test "x$HAVE_MEMFD" = "x1"], AC_DEFINE([HAVE_MEMFD], 1, [Have memfd shared memory.]))
+diff --git a/src/pulsecore/memfd-wrappers.h b/src/pulsecore/memfd-wrappers.h
+index 3bed9b2..c7aadfd 100644
+--- a/src/pulsecore/memfd-wrappers.h
++++ b/src/pulsecore/memfd-wrappers.h
+@@ -20,13 +20,14 @@
+ License along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.
+ ***/
+
+-#ifdef HAVE_MEMFD
++#if defined(HAVE_MEMFD) && !defined(HAVE_MEMFD_CREATE)
+
+ #include <sys/syscall.h>
+ #include <fcntl.h>
+
+ /*
+- * No glibc wrappers exist for memfd_create(2), so provide our own.
++ * Before glibc version 2.27 there was no wrapper for memfd_create(2),
++ * so we have to provide our own.
+ *
+ * Also define memfd fcntl sealing macros. While they are already
+ * defined in the kernel header file <linux/fcntl.h>, that file as
+@@ -63,6 +64,6 @@ static inline int memfd_create(const char *name, unsigned int flags) {
+ #define F_SEAL_WRITE 0x0008 /* prevent writes */
+ #endif
+
+-#endif /* HAVE_MEMFD */
++#endif /* HAVE_MEMFD && !HAVE_MEMFD_CREATE */
+
+ #endif
diff --git a/media-sound/pulseaudio/pulseaudio-11.1-r1.ebuild b/media-sound/pulseaudio/pulseaudio-11.1-r1.ebuild
index f9aee0517a38..1a8c69657ddc 100644
--- a/media-sound/pulseaudio/pulseaudio-11.1-r1.ebuild
+++ b/media-sound/pulseaudio/pulseaudio-11.1-r1.ebuild
@@ -116,7 +116,10 @@ RDEPEND="${RDEPEND}
)
"
-PATCHES=( "${FILESDIR}/${P}"-qpaeq-pyqt5-{1,2}.patch )
+PATCHES=(
+ "${FILESDIR}/${P}"-qpaeq-pyqt5-{1,2}.patch
+ "${FILESDIR}/${P}"-glibc-2.27.patch
+)
pkg_pretend() {
CONFIG_CHECK="~HIGH_RES_TIMERS"