summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-09-26 08:06:32 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-09-26 08:06:32 +0200
commit0d1ed7809f22ecf07a80c7788e84353d4c70606b (patch)
tree51d3b6b35e0893743211f30065642c11d9e36d54 /media-sound
parentapp-i18n/nkf: Stabilize 2.1.5 sparc, #814869 (diff)
downloadgentoo-0d1ed7809f22ecf07a80c7788e84353d4c70606b.tar.gz
gentoo-0d1ed7809f22ecf07a80c7788e84353d4c70606b.tar.bz2
gentoo-0d1ed7809f22ecf07a80c7788e84353d4c70606b.zip
media-sound/din: bump to 51.1.1
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/din/Manifest1
-rw-r--r--media-sound/din/din-51.1.1.ebuild57
-rw-r--r--media-sound/din/files/din-51.1.1-makefile.patch14
3 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/din/Manifest b/media-sound/din/Manifest
index 6e4cb9bfdb81..e93a4b9f3885 100644
--- a/media-sound/din/Manifest
+++ b/media-sound/din/Manifest
@@ -1 +1,2 @@
DIST din-50.2.tar.gz 3687036 BLAKE2B b51923d755c5b4635d79c77f204bf42da9926fc247dde9d3ad175bc858a674a3064589608bfd67331ef40a417fdbbee4e90ae6a9bc2930355213738225fcd7e4 SHA512 4d60f26434559259b778181f2b46e2689af94179fc254b61e1ea623cafa49030736b69effd82fb2f62b8e908883cf272147dde884487c9a7beed9c26cf0a7498
+DIST din-51.1.1.tar.gz 3700797 BLAKE2B 559a4476188ac6d9da596be011bdaa8b379bb336220b3f94edf04e3eeb9ca0100fbaaa0fc10f9a9f37d3efa436acddac5c06435c6b3ebb4d21afdbd7c65b2dc8 SHA512 ea5e1ab79cbc24abb80a9fd25d8304f36ab2345505ee98132196685cda73b31dd7db3f62cb1821cbdc9694703d3454bd58d733833710d492ecebffee23732a0f
diff --git a/media-sound/din/din-51.1.1.ebuild b/media-sound/din/din-51.1.1.ebuild
new file mode 100644
index 000000000000..4c4933184e27
--- /dev/null
+++ b/media-sound/din/din-51.1.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools edos2unix xdg
+
+DESCRIPTION="a software musical instrument and audio synthesizer"
+HOMEPAGE="https://dinisnoise.org/"
+SRC_URI="https://archive.org/download/dinisnoise_source_code/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+alsa jack"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ media-libs/libsdl:=
+ virtual/glu
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ jack? ( virtual/jack )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="|| ( alsa jack )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${PN}-48-fix-random-constants.patch"
+)
+
+src_prepare() {
+ default
+
+ edos2unix pixmaps/${PN}.desktop
+
+ use jack && (sed -i "s/-lasound/-ljack/g" src/Makefile.am || die "Failed to fix jack linking")
+
+ eautoreconf
+}
+
+src_configure() {
+ # Jack takes over alsa.
+ local sound_engine
+
+ use jack && sound_engine="UNIX_JACK" || sound_engine="LINUX_ALSA"
+
+ econf CXXFLAGS="${CXXFLAGS} -D__${sound_engine}__"
+}
diff --git a/media-sound/din/files/din-51.1.1-makefile.patch b/media-sound/din/files/din-51.1.1-makefile.patch
new file mode 100644
index 000000000000..9909080a9b54
--- /dev/null
+++ b/media-sound/din/files/din-51.1.1-makefile.patch
@@ -0,0 +1,14 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 377dc4c..b086c0c 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,7 +1,7 @@
+ #dinincludedir = $(pkgsrcdir)
+
+-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
+-LIBS += -ltcl8.6 -lSDL -lGL -lpthread -lasound
++AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D __SVG__ -D__GPL20__ -D __BOOST_TIME__ -DPREFIX=\"@prefix@\"
++LIBS += -ltcl -lSDL -lGL -lpthread -lasound
+
+ bin_PROGRAMS = din
+ din_SOURCES = alarm.cc arrow_button.cc audio.cc authors_note.cc ball.cc ball_ops.cc basic_editor.cc beat2value.cc binaural_drone.cc binaural_drones.cc bit_display.cc box_selector.cc button.cc capturer.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc curve_samples.cc custom_periodic.cc delay.cc din.cc din_info.cc drawrrow.cc drone.cc eval.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc hit.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc modulator.cc mondrian.cc morpher.cc morse_code.cc mouse_slider.cc multi_curve.cc note.cc noiser.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc point_modulator.cc range.cc recorder.cc rect.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc slit.cc solver.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp