summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-10-30 13:45:22 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-10-30 13:45:22 +0100
commit8cec6e3fb55c3bece262ca88c46583ee778733f1 (patch)
tree64eed21915f6f6dc484f349eb464a924a0ca82b3 /media-sound
parentmedia-plugins/x42-plugins: bump to 20240611 (diff)
downloadgentoo-8cec6e3fb55c3bece262ca88c46583ee778733f1.tar.gz
gentoo-8cec6e3fb55c3bece262ca88c46583ee778733f1.tar.bz2
gentoo-8cec6e3fb55c3bece262ca88c46583ee778733f1.zip
media-sound/vmpk: bump to 0.9.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/vmpk/Manifest1
-rw-r--r--media-sound/vmpk/vmpk-0.9.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/vmpk/Manifest b/media-sound/vmpk/Manifest
index 703c453b0f91..1228beb61d5b 100644
--- a/media-sound/vmpk/Manifest
+++ b/media-sound/vmpk/Manifest
@@ -1 +1,2 @@
DIST vmpk-0.8.7.tar.bz2 483742 BLAKE2B 788c70034fcfb53edfb4c6b0faf80c06e2ae096c06819bc727359d4597cb217ca60efc9ebbbb19b223dc0d7106ddd9083abbce881f175b98203f3b6acc9b44e2 SHA512 83867aed8be8e620e18070d5eba9f5e4026b1f39ff9d7fe55e342d4a040c96e2353844296191c0efb46483254b1d2d30824894077562a165f7474d02a882cfc6
+DIST vmpk-0.9.0.tar.bz2 449608 BLAKE2B 80827907ac32788c687ff71170afec2de32a02cc9f1096b5af5e1cc6a43c513efbbd5f9dc443cf2d56a536c158b343a362fccb57814c99d9891a5a5b7c83d5ff SHA512 7e84daa0664bc9d403df6c7bd5a226ea37c4804c49e4bcfb2e4f141e257e0081b752e9c2bddc29a9d2eda8bcb06b8ed1c79d129e55d601dfb58951449ebf454f
diff --git a/media-sound/vmpk/vmpk-0.9.0.ebuild b/media-sound/vmpk/vmpk-0.9.0.ebuild
new file mode 100644
index 000000000000..5550532effed
--- /dev/null
+++ b/media-sound/vmpk/vmpk-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Virtual MIDI Piano Keyboard"
+HOMEPAGE="https://vmpk.sourceforge.io/"
+SRC_URI="https://downloads.sourceforge.net/vmpk/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-qt/qtbase:6[gui,network,widgets]
+ >=media-sound/drumstick-2.6.0
+ x11-libs/libxcb
+ dbus? ( dev-qt/qtbase:6[dbus] )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DBUS=$(usex dbus)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/vmpk/*.html "${D}"/usr/share/doc/${PF}/html/ || die
+}