summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-07 10:32:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-07 10:39:25 +0100
commit97924bf9e27524cf0a106003aeef6da4410b262b (patch)
treeaf2d6e0657ae2c0fdcc20cbdf39794fbdbc401d4 /media-sound
parentdev-libs/opensc: drop 0.23.0-r3 (diff)
downloadgentoo-97924bf9e27524cf0a106003aeef6da4410b262b.tar.gz
gentoo-97924bf9e27524cf0a106003aeef6da4410b262b.tar.bz2
gentoo-97924bf9e27524cf0a106003aeef6da4410b262b.zip
media-sound/qastools: add 1.4.0, switched to Qt6
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qastools/Manifest1
-rw-r--r--media-sound/qastools/qastools-1.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/media-sound/qastools/Manifest b/media-sound/qastools/Manifest
index aecf7481de9d..582cda61bd85 100644
--- a/media-sound/qastools/Manifest
+++ b/media-sound/qastools/Manifest
@@ -1 +1,2 @@
DIST qastools-v0.23.0.tar.gz 292875 BLAKE2B c0ba54462e702411bee7a15a913617870488b1c9c2676e3c6f69d0648cff79cc1989e0f367953ba6f27b94c014c9b2fa7ef74ae4800d03b99bb8336ce4535d4a SHA512 79042a41a0ad37097d297175b899af73052953b7ae14058a1878e3145769db839b8bd4350bd36646d8436a3e8b37b64da7b3004bee3c7c7780d46a942af1d3b9
+DIST qastools-v1.4.0.tar.gz 304640 BLAKE2B 4a48ea32b41d03739497764f9677a79a0ca0f917fa758acab4ae61d776fe79d4d8b7cc6d3bfed657aafc241c2bf57d7d469184b2b95084c999133480faa8b5b6 SHA512 eced94ce0c796148d3dae79f8b687d481b2adb34466de41ad0c6ecf3b820562297720d8052332c3f1ba422a856dbc7742f1bdb2a32b6bb1c43eaad9cba256946
diff --git a/media-sound/qastools/qastools-1.4.0.ebuild b/media-sound/qastools/qastools-1.4.0.ebuild
new file mode 100644
index 000000000000..fd5462cfef8f
--- /dev/null
+++ b/media-sound/qastools/qastools-1.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt GUI ALSA tools: mixer, configuration browser"
+HOMEPAGE="https://gitlab.com/sebholt/qastools"
+SRC_URI="https://gitlab.com/sebholt/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-v${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtbase:6[dbus,gui,network,widgets]
+ dev-qt/qtsvg:6
+ media-libs/alsa-lib
+ virtual/libudev:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+PATCHES=( "${FILESDIR}/${PN}-0.23.0-nomancompress.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSKIP_LICENSE_INSTALL=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_UnixCommands=ON
+ )
+ cmake_src_configure
+}