summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2019-11-13 10:49:45 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2019-11-13 10:52:39 +0100
commitdb1ea43e9bd591385324e58f1e33ed03e3ca3231 (patch)
tree3e7c0973cd2a9361079764b4f0128392a3e9e406 /media-sound
parentkde-plasma/plasma-workspace-wallpapers: Previous fix requires a revbump (diff)
downloadgentoo-db1ea43e9bd591385324e58f1e33ed03e3ca3231.tar.gz
gentoo-db1ea43e9bd591385324e58f1e33ed03e3ca3231.tar.bz2
gentoo-db1ea43e9bd591385324e58f1e33ed03e3ca3231.zip
media-sound/a2jmidid-{9,9999}: bump + added live
1) changed to live project on github.com 2) ebuild rewritten to use mason 3) EAPI-7 4) added BDEPEND 5) updated DOCS Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/a2jmidid/Manifest1
-rw-r--r--media-sound/a2jmidid/a2jmidid-9.ebuild37
-rw-r--r--media-sound/a2jmidid/a2jmidid-9999.ebuild37
3 files changed, 75 insertions, 0 deletions
diff --git a/media-sound/a2jmidid/Manifest b/media-sound/a2jmidid/Manifest
index 28e71223b110..d5e808090f52 100644
--- a/media-sound/a2jmidid/Manifest
+++ b/media-sound/a2jmidid/Manifest
@@ -1 +1,2 @@
DIST a2jmidid-8.tar.bz2 162764 BLAKE2B 4c173d458bc9bf393496bc53dcd92e796826386f3d2704f6d1fc108dd7e4fb660271cc2befec655b516dd669189fb01c23576fdd39c1c23b485346390edfb0a7 SHA512 6182a295462ae587461ca395d85c956523bfecd113d031d0ae8a9f304fc3d41f6a5097b3a1a9fc06bd0eef7fe08a4b3c116a3361ff9e63468c3e40b736215592
+DIST a2jmidid-9.tar.gz 47925 BLAKE2B ad079e76a54f56ee8f82150c306f91aead52f86632978ea6f3376a0bf163744379210b34701b39da4ee14fc4d8a1c6be82d1052abeb8ccf79410bc242d174d62 SHA512 5bd13b6904ed68c5bfe40ca516fd49b7eb4d4a946b9908ee04687265848734c8e1a81579f0f1a5bd0752595be8858dc748da10487b7f366394c09a5ffc7d5e5c
diff --git a/media-sound/a2jmidid/a2jmidid-9.ebuild b/media-sound/a2jmidid/a2jmidid-9.ebuild
new file mode 100644
index 000000000000..8879e053f463
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
+SRC_URI="https://github.com/linuxaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/alsa-lib
+ virtual/jack
+ dbus? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
+
+src_configure() {
+ local emasonargs=(
+ -Ddisable-dbus=$(usex dbus false true)
+ )
+
+ meson_src_configure
+}
diff --git a/media-sound/a2jmidid/a2jmidid-9999.ebuild b/media-sound/a2jmidid/a2jmidid-9999.ebuild
new file mode 100644
index 000000000000..c3d3a8ed15a2
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson git-r3
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
+EGIT_REPO_URI="https://github.com/linuxaudio/a2jmidid.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="dbus"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+CDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/alsa-lib
+ virtual/jack
+ dbus? ( sys-apps/dbus )
+"
+RDEPEND="${CDEPEND}"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst README.rst internals.txt )
+
+src_configure() {
+ local emasonargs=(
+ -Ddisable-dbus=$(usex dbus false true)
+ )
+
+ meson_src_configure
+}