summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-10-17 12:11:14 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-17 12:11:14 +0200
commited1e95300e514a93a1d975907401eae9162f6c51 (patch)
tree8776971619607ba05e51da42605efcdc74a18dd3 /media-sound
parentmedia-sound/poc: Port to EAPI 7 (diff)
downloadgentoo-ed1e95300e514a93a1d975907401eae9162f6c51.tar.gz
gentoo-ed1e95300e514a93a1d975907401eae9162f6c51.tar.bz2
gentoo-ed1e95300e514a93a1d975907401eae9162f6c51.zip
media-sound/rawrec: Port to EAPI 7
Bug: https://bugs.gentoo.org/697272 Package-Manager: Portage-2.3.77, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/rawrec/files/rawrec-0.9.991-fix-build-system.patch24
-rw-r--r--media-sound/rawrec/rawrec-0.9.991.ebuild29
2 files changed, 39 insertions, 14 deletions
diff --git a/media-sound/rawrec/files/rawrec-0.9.991-fix-build-system.patch b/media-sound/rawrec/files/rawrec-0.9.991-fix-build-system.patch
new file mode 100644
index 000000000000..bef125094f13
--- /dev/null
+++ b/media-sound/rawrec/files/rawrec-0.9.991-fix-build-system.patch
@@ -0,0 +1,24 @@
+--- a/Makefile
++++ b/Makefile
+@@ -6,19 +6,15 @@
+ HEADERS = $(wildcard *.h)
+ OBJS = $(patsubst %.c,%.o,$(wildcard *.c))
+
+-CC = gcc
+ WARNFLAGS = -Wall -W -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes
+-DEBUGFLAGS = -O0 -g
+-OPTFLAGS = -O2
+
+ # Uncomment this to try to use untested priority ceiling/inheritance
+ # code (if system supports it).
+ #FANCY_THREAD_DEFINES = -DUSE_FANCY_PRIORITY_CODE
+
+ # FIXME: USEBUFFLOCK appears to be historic, and should probably go some day.
+-CFLAGS = $(WARNFLAGS) $(OPTFLAGS) $(DEBUGFLAGS) -DUSEBUFFLOCK \
+- $(FANCY_THREAD_DEFINES) -D_REENTRANT -D_GNU_SOURCE \
+- -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
++CFLAGS += $(WARNFLAGS)
++CPPFLAGS += -DUSEBUFFLOCK -D_REENTRANT -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
+ LIBS = -lm -lpthread
+
+ # The GNU way is just too painful. I'm not writing three tiers of
diff --git a/media-sound/rawrec/rawrec-0.9.991.ebuild b/media-sound/rawrec/rawrec-0.9.991.ebuild
index 24377e072281..3372ddccaf5f 100644
--- a/media-sound/rawrec/rawrec-0.9.991.ebuild
+++ b/media-sound/rawrec/rawrec-0.9.991.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit flag-o-matic toolchain-funcs eutils
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="CLI program to play and record audiofiles"
HOMEPAGE="http://rawrec.sourceforge.net"
@@ -12,23 +12,24 @@ SRC_URI="mirror://sourceforge/rawrec/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
-IUSE=""
-S="${S}"/src
+S="${WORKDIR}/${P}/src"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-libs.patch"
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-libs.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_compile() {
- emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die "emake failed."
+src_configure() {
+ tc-export CC
}
src_install() {
- emake EXE_DIR="${D}/usr/bin" \
- MAN_DIR="${D}/usr/share/man/man1" install || die "emake install failed."
+ dobin rawrec
+ dosym rawrec /usr/bin/rawplay
+
+ doman ../docs/user/rawrec.1
+ dosym rawrec.1 /usr/share/man/man1/rawplay.1
einfo "Removing SUID from binary.."
fperms 755 /usr/bin/rawrec