summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-03-29 17:41:30 -0400
committerMatt Turner <mattst88@gentoo.org>2023-03-29 17:51:11 -0400
commitca5e4fe4f7dcc4849dc7c9c622626105276d24f8 (patch)
treed809be3eec569cd26536f82e6c0f0df82233afcd /media-video/libva-utils
parentmedia-libs/libva-intel-media-driver: Drop old versions (diff)
downloadgentoo-ca5e4fe4f7dcc4849dc7c9c622626105276d24f8.tar.gz
gentoo-ca5e4fe4f7dcc4849dc7c9c622626105276d24f8.tar.bz2
gentoo-ca5e4fe4f7dcc4849dc7c9c622626105276d24f8.zip
media-video/libva-utils: Version bump to 2.18.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-video/libva-utils')
-rw-r--r--media-video/libva-utils/Manifest1
-rw-r--r--media-video/libva-utils/libva-utils-2.18.1.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-video/libva-utils/Manifest b/media-video/libva-utils/Manifest
index 5af9a28bbe3b..0451112414f9 100644
--- a/media-video/libva-utils/Manifest
+++ b/media-video/libva-utils/Manifest
@@ -1,2 +1,3 @@
DIST libva-utils-2.16.0.tar.gz 1245723 BLAKE2B 3ce3b54f9b8d1e5960fdb7587da9dc4fa9754f3612155e86d99f2f120e31e0e69a40482d7a4571fefc0a8079ba987303cbb433203de9ef6e203e9419b6d91b91 SHA512 d5395c1de4b95f4d0a86621b0338852250a3893b732c6fd69d0622c989bff530461a183c151f322469b1ed7e4815173dbbcf36cc390db9ebbae6fb7d7a90cb9c
DIST libva-utils-2.17.1.tar.gz 1276454 BLAKE2B bde2b784c6470721b113d5a4429ac0b02b922a6bf37d3554d4c088736d184cb8d8107b714e37d0ba517fd9a52ba43247cd4985604421b5e63af841b649786366 SHA512 db89f70c6efb34d0e390a443b29d706ac6339e157e6451a96aa50d4246ce08b8276608874f20d115a2576b8876c95a2e34abba8fe0a446f6736a807779517c6c
+DIST libva-utils-2.18.1.tar.gz 1279583 BLAKE2B 84620e1c9cd24c0cddc4df93e598d858cec299af3a6776c3ee723be8cad3061f5d433d5d9ec1ff97f801ad5f14db93ef021c7bb40d7c7898d8d04fb9ac15ed07 SHA512 b83ac6395715b1970d56c4b03ac0331f444dad7e4159f00ce5891401c97aaac101a5be2b2123e2fe31350f7c09cd665e38ed01541c1be95b3d3ef822cafd6dea
diff --git a/media-video/libva-utils/libva-utils-2.18.1.ebuild b/media-video/libva-utils/libva-utils-2.18.1.ebuild
new file mode 100644
index 000000000000..f2d6709a0a66
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-2.18.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/libva-utils"
+else
+ SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples putsurface test +vainfo wayland X"
+RESTRICT="test" # Tests must be run manually
+
+REQUIRED_USE="
+ putsurface? ( || ( wayland X ) )
+ || ( examples putsurface test vainfo )
+"
+
+DEPEND="
+ x11-libs/libdrm
+ wayland? ( >=dev-libs/wayland-1.0.6 )
+ X? ( >=x11-libs/libX11-1.6.2 )
+"
+if [[ ${PV} = *9999 ]] ; then
+ DEPEND+="~media-libs/libva-${PV}:=[wayland?,X?]"
+else
+ DEPEND+=">=media-libs/libva-$(ver_cut 1-2).0:=[wayland?,X?]"
+fi
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ local sed_args=()
+
+ if ! use examples ; then
+ sed_args+=(
+ -e "/^ subdir('decode')$/d"
+ -e "/^ subdir('encode')$/d"
+ -e "/^ subdir('videoprocess')$/d"
+ -e "/^ subdir('vendor\/intel')$/d"
+ -e "/^ subdir('vendor\/intel\/sfcsample')$/d"
+ )
+ fi
+
+ if ! use putsurface ; then
+ sed_args+=(-e "/^ subdir('putsurface')$/d")
+ fi
+
+ if ! use vainfo ; then
+ sed_args+=(-e "/^subdir('vainfo')$/d")
+ fi
+
+ if [[ ${#sed_args[@]} -gt 0 ]] ; then
+ sed "${sed_args[@]}" -i meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddrm=true
+ $(meson_use X x11)
+ $(meson_use wayland)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use test ; then
+ rm -f "${ED}"/usr/bin/test_va_api || die
+ fi
+}
+
+pkg_postinst() {
+ if use test ; then
+ elog "Tests must be run manually with the test_va_api binary"
+ fi
+}