summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild')
-rw-r--r--media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild b/media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild
new file mode 100644
index 000000000000..8a645260ef2f
--- /dev/null
+++ b/media-video/mplayer-sh/mplayer-sh-0.8.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+RESTRICT="mirror bindist"
+
+DESCRIPTION="Video Disk Recorder Mplayer API Script"
+HOMEPAGE="http://batleth.sapienti-sat.org/projects/VDR/"
+SRC_URI="http://batleth.sapienti-sat.org/projects/VDR/versions/mplayer.sh-${PV}.tar.gz"
+
+KEYWORDS="x86 ~amd64"
+SLOT="0"
+LICENSE="all-rights-reserved"
+IUSE=""
+
+RDEPEND=">=media-video/mplayer-0.1.20070321"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-parameter-aid.diff"
+
+ sed -i "s:^declare CFGFIL.*$:declare CFGFIL=\"\/etc\/vdr\/plugins\/mplayer\/mplayer.sh.conf\":" mplayer.sh
+ sed -i mplayer.sh.conf -e "s:^LIRCRC.*$:LIRCRC=\/etc\/lircd.conf:" \
+ -e "s:^MPLAYER=.*$:MPLAYER=\/usr\/bin\/mplayer:"
+}
+
+src_install() {
+
+ insinto /etc/vdr/plugins/mplayer
+ doins mplayer.sh.conf
+
+ into /usr/share/vdr/mplayer
+ dobin mplayer.sh
+
+ dodir /etc/vdr/plugins/DVD-VCD
+ touch "${D}"/etc/vdr/plugins/DVD-VCD/{DVD,VCD}
+ fowners vdr:vdr /etc/vdr/plugins/DVD-VCD/{DVD,VCD}
+}