summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiklāvs Koļesņikovs <89q1r14hd@relay.firefox.com>2021-09-24 01:10:26 +0300
committerSam James <sam@gentoo.org>2021-09-24 00:02:22 +0100
commitff521b5b8ddc11fe0fe516cf3764f1b93592ad2f (patch)
tree0dd5d4e94a5d38e57a56cff33af1ffbd725c9859 /media-video/pipewire
parentapp-portage/recover-broken-vdb: keyword 0.0.3 for ~amd64 (diff)
downloadgentoo-ff521b5b8ddc11fe0fe516cf3764f1b93592ad2f.tar.gz
gentoo-ff521b5b8ddc11fe0fe516cf3764f1b93592ad2f.tar.bz2
gentoo-ff521b5b8ddc11fe0fe516cf3764f1b93592ad2f.zip
media-video/pipewire: instruct users to disable oFono
Upstream has changed the logic to no longer automatically use oFono if it's found running. This is because other Linux distributions had it running by default but not properly configured, which would also break PipeWire's Bluetooth support. Unfortunately, this means that now a running oFono is at risk of conflicting with the native backend, which is the new default behavior. Since most use cases are expected to work with the native backend, the easiest solution is to advise users to disable oFono service, and that is what this PR does. Thanks-to: Jannik Glückert <jannik.glueckert@gmail.com> (systemd inst.) Thanks-to: Sam James <sam@gentoo.org> (OpenRC instructions) Signed-off-by: Niklāvs Koļesņikovs <89q1r14hd@relay.firefox.com> Closes: https://github.com/gentoo/gentoo/pull/22380 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/pipewire')
-rw-r--r--media-video/pipewire/pipewire-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/media-video/pipewire/pipewire-9999.ebuild b/media-video/pipewire/pipewire-9999.ebuild
index c601ceab2539..7725dfa300f5 100644
--- a/media-video/pipewire/pipewire-9999.ebuild
+++ b/media-video/pipewire/pipewire-9999.ebuild
@@ -5,7 +5,7 @@ EAPI="7"
PYTHON_COMPAT=( python3_{8..10} )
-inherit meson-multilib optfeature python-any-r1 udev
+inherit meson-multilib optfeature python-any-r1 systemd udev
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
@@ -273,9 +273,13 @@ pkg_postinst() {
optfeature_header "The following can be installed for optional runtime features:"
optfeature "restricted realtime capabilities via D-Bus" sys-auth/rtkit
- # Once hsphfpd lands in tree, both it and ofono will need to be checked for presence here!
- if use bluetooth; then
- optfeature "better BT headset support (daemon startup required)" net-misc/ofono
- #optfeature "an oFono alternative (not packaged)" foo-bar/hsphfpd
+ if has_version 'net-misc/ofono' ; then
+ ewarn "Native backend has become default. Please disable oFono via:"
+ if systemd_is_booted ; then
+ ewarn "systemctl disable --now ofono"
+ else
+ ewarn "rc-update delete ofono"
+ fi
+ ewarn
fi
}