summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-12 15:17:21 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-12 15:28:59 +0100
commite0c8fc85343ddba298c0ab46a4a685ed4a43d237 (patch)
tree0ca7c57c166517883fcfecce887825ffce2f6b3b /media-video/pitivi
parentdev-python/pyxdg: Support python 3.5 (diff)
downloadgentoo-e0c8fc85343ddba298c0ab46a4a685ed4a43d237.tar.gz
gentoo-e0c8fc85343ddba298c0ab46a4a685ed4a43d237.tar.bz2
gentoo-e0c8fc85343ddba298c0ab46a4a685ed4a43d237.zip
media-video/pitivi: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'media-video/pitivi')
-rw-r--r--media-video/pitivi/Manifest1
-rw-r--r--media-video/pitivi/pitivi-0.95.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-video/pitivi/Manifest b/media-video/pitivi/Manifest
index 625bb56ed5c2..7418515a01e7 100644
--- a/media-video/pitivi/Manifest
+++ b/media-video/pitivi/Manifest
@@ -1 +1,2 @@
DIST pitivi-0.94.tar.xz 3271200 SHA256 f52a0643bc5a9149069c01d0b5ef4149032473bb505e6d679dd3f3153506faec SHA512 fcf3ccb537980418af55ead196963b3503d407e23fcaf7409898c9c3e61077ae7491d91c82f6fa3eb63182a383035e1ec2ada4f046ec9b7cdf9f02829662c3c3 WHIRLPOOL c308595a582f304f8910fd04aadcfebe9743b560db48165247feb15065694441441564feb91e13a609f3d9344be05be369094b2e52638bd9a6525e95a1a00acd
+DIST pitivi-0.95.tar.xz 3341488 SHA256 5f15220bcc3d02cef4edacaa19da284014caf725e41fc9cbec70469582e1d313 SHA512 e628302ecbb790e955459a4dc124e8580081f6eff8abde210a1b537ae18696c3861bd619efe1434e8e1cf1069adb72cbff0cf44c64706c4046d2cfb7f9aecdfa WHIRLPOOL df6e625dddcf113a8e84aabf5a7a40d90e6b38130e63201a1674f4a576a735696c6b9a9a35b2743cbe5bac8d444c04cd0ea9c5a43358718e1b32b6ebc97f435c
diff --git a/media-video/pitivi/pitivi-0.95.ebuild b/media-video/pitivi/pitivi-0.95.ebuild
new file mode 100644
index 000000000000..583aad287d17
--- /dev/null
+++ b/media-video/pitivi/pitivi-0.95.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{3_3,3_4,3_5} )
+PYTHON_REQ_USE="sqlite"
+
+inherit gnome2 python-single-r1 virtualx
+
+DESCRIPTION="A non-linear video editor using the GStreamer multimedia framework"
+HOMEPAGE="http://www.pitivi.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="v4l test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Do not forget to check pitivi/check.py for dependencies
+# pycanberra, gnome-desktop, libav and libnotify are optional
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/pycairo-1.10[${PYTHON_USEDEP}]
+ >=x11-libs/cairo-1.10
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-libs/glib-2.30.0:2
+
+ >=dev-libs/gobject-introspection-1.34:=
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/gst-python-1.4:1.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pycanberra[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.8:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+
+ gnome-base/librsvg:=
+ gnome-base/gnome-desktop:3=[introspection]
+
+ >=media-libs/gstreamer-1.6.0:1.0[introspection]
+ >=media-libs/gstreamer-editing-services-1.6.0:1.0[introspection]
+ >=media-libs/gst-plugins-base-1.6.0:1.0
+ >=media-libs/gst-plugins-bad-1.6.1:1.0[gtk]
+ >=media-libs/gst-plugins-good-1.6.0:1.0
+ >=media-plugins/gst-plugins-libav-1.6.0:1.0
+
+ x11-libs/libnotify[introspection]
+ >=x11-libs/gtk+-3.10.0:3[introspection]
+
+ v4l? ( >=media-plugins/gst-plugins-v4l2-1.4:1.0 )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-python/setuptools
+ >=dev-util/intltool-0.35.5
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static
+}
+
+src_test() {
+ # Force Xvfb to be used
+ unset DISPLAY
+ export PITIVI_TOP_LEVEL_DIR="${S}"
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+ python_fix_shebang "${D}"
+}