summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-04 00:36:29 -0500
committerSam James <sam@gentoo.org>2024-03-04 05:47:11 +0000
commite287404a043cf110b9982dc3493877fd7b14f08c (patch)
tree5a97da3e8ea4daff2896a318c54876866b8e8899 /media-video/rav1e
parentmedia-video/rav1e: use cargo.eclass functions to build (diff)
downloadgentoo-e287404a043cf110b9982dc3493877fd7b14f08c.tar.gz
gentoo-e287404a043cf110b9982dc3493877fd7b14f08c.tar.bz2
gentoo-e287404a043cf110b9982dc3493877fd7b14f08c.zip
media-video/rav1e: unvendor libgit2 from rust dependency
It is actually only used at build time, by this... thing: https://crates.io/crates/built Apparently it is of the utmost importance that when you get the version info from your git checkout of the project, you do so with blazing-fast fearless concurrency, and if that means spending several minutes compiling a git implementation instead of running /usr/bin/git, then no price is too large. Fearless concurrency for the win! Onward! Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video/rav1e')
-rw-r--r--media-video/rav1e/rav1e-0.7.1.ebuild5
-rw-r--r--media-video/rav1e/rav1e-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/media-video/rav1e/rav1e-0.7.1.ebuild b/media-video/rav1e/rav1e-0.7.1.ebuild
index 3f21fd7d33c8..6e51df483cb6 100644
--- a/media-video/rav1e/rav1e-0.7.1.ebuild
+++ b/media-video/rav1e/rav1e-0.7.1.ebuild
@@ -265,6 +265,8 @@ BDEPEND="
amd64? ( ${ASM_DEP} )
capi? ( >=dev-util/cargo-c-0.6.3 )
"
+# only used as a build script to check the version of rav1e...
+DEPEND="dev-libs/libgit2"
# Rust
QA_FLAGS_IGNORED="usr/lib.*/librav1e.* usr/bin/rav1e"
@@ -280,6 +282,9 @@ src_unpack() {
}
src_compile() {
+ # used by build script to get rav1e repository info
+ export LIBGIT2_NO_VENDOR=1
+
cargo_src_compile
if use capi; then
diff --git a/media-video/rav1e/rav1e-9999.ebuild b/media-video/rav1e/rav1e-9999.ebuild
index 3f21fd7d33c8..6e51df483cb6 100644
--- a/media-video/rav1e/rav1e-9999.ebuild
+++ b/media-video/rav1e/rav1e-9999.ebuild
@@ -265,6 +265,8 @@ BDEPEND="
amd64? ( ${ASM_DEP} )
capi? ( >=dev-util/cargo-c-0.6.3 )
"
+# only used as a build script to check the version of rav1e...
+DEPEND="dev-libs/libgit2"
# Rust
QA_FLAGS_IGNORED="usr/lib.*/librav1e.* usr/bin/rav1e"
@@ -280,6 +282,9 @@ src_unpack() {
}
src_compile() {
+ # used by build script to get rav1e repository info
+ export LIBGIT2_NO_VENDOR=1
+
cargo_src_compile
if use capi; then