summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/videocut
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/videocut')
-rw-r--r--media-video/videocut/Manifest1
-rw-r--r--media-video/videocut/files/01-fix-hardened-ftbfs.diff16
-rw-r--r--media-video/videocut/files/videocut3
-rw-r--r--media-video/videocut/metadata.xml12
-rw-r--r--media-video/videocut/videocut-0.2.0.ebuild41
5 files changed, 73 insertions, 0 deletions
diff --git a/media-video/videocut/Manifest b/media-video/videocut/Manifest
new file mode 100644
index 000000000000..c7b8c9c9d4c0
--- /dev/null
+++ b/media-video/videocut/Manifest
@@ -0,0 +1 @@
+DIST videocut_0.2.0.tar.gz 146915 SHA256 234abbf01848150a1a74cb3b886a6021ec77c7f936991db26c082778c93ce1e1
diff --git a/media-video/videocut/files/01-fix-hardened-ftbfs.diff b/media-video/videocut/files/01-fix-hardened-ftbfs.diff
new file mode 100644
index 000000000000..47fe7f97842c
--- /dev/null
+++ b/media-video/videocut/files/01-fix-hardened-ftbfs.diff
@@ -0,0 +1,16 @@
+# Fix FTBFS with enabled hardened flags and gcc-4.6 failure
+# https://bugs.gentoo.org/show_bug.cgi?id=380439
+
+--- a/src/TPreviewPanel/TPreviewPanel.cpp
++++ b/src/TPreviewPanel/TPreviewPanel.cpp
+@@ -167,7 +167,9 @@
+
+ void TPreviewPanel::adjustItems()
+ {
+- backgroundRect->setSize(&QRectF(0, 0, 1, 1));
++ QRectF myRect(0, 0, 1, 1);
++ backgroundRect->setSize(&myRect);
++
+ logo->setSize(QRect(0, 0, 1, 1));
+
+ // adjust meta text
diff --git a/media-video/videocut/files/videocut b/media-video/videocut/files/videocut
new file mode 100644
index 000000000000..5a33c7232fcb
--- /dev/null
+++ b/media-video/videocut/files/videocut
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/videocut
+exec /usr/libexec/videocut
diff --git a/media-video/videocut/metadata.xml b/media-video/videocut/metadata.xml
new file mode 100644
index 000000000000..3ab9197e8603
--- /dev/null
+++ b/media-video/videocut/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">videocut</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/videocut/videocut-0.2.0.ebuild b/media-video/videocut/videocut-0.2.0.ebuild
new file mode 100644
index 000000000000..cf372a08b4d7
--- /dev/null
+++ b/media-video/videocut/videocut-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils qt4-r2
+
+DESCRIPTION="A program to create compositions from video files"
+HOMEPAGE="http://code.google.com/p/videocut/"
+SRC_URI="http://${PN}.googlecode.com/files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ media-libs/xine-lib"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}.orig
+
+PATCHES=( "${FILESDIR}"/01-fix-hardened-ftbfs.diff )
+
+src_compile() {
+ emake || die
+ lrelease i18n/*.ts
+}
+
+src_install() {
+ exeinto /usr/libexec
+ doexe build/result/${PN} || die
+ dobin "${FILESDIR}"/${PN} || die
+ insinto /usr/share/${PN}/i18n
+ doins -r i18n/*.qm || die
+ domenu ${PN}.desktop
+ doicon videocut.svg
+ dodoc ABOUT AUTHORS THANKSTO
+}