summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 00:22:02 +0000
committerSam James <sam@gentoo.org>2022-03-20 00:22:02 +0000
commitb6abf5c883941d584c33b40e3014a005ca323b61 (patch)
tree62d10fa9e8e3a3bde9b8f9adac329b91f628e750 /media-video
parentnet-p2p/gtk-gnutella: [QA] fix tc-get* quoting (diff)
downloadgentoo-b6abf5c883941d584c33b40e3014a005ca323b61.tar.gz
gentoo-b6abf5c883941d584c33b40e3014a005ca323b61.tar.bz2
gentoo-b6abf5c883941d584c33b40e3014a005ca323b61.zip
media-video/mplayer-sh: drop 0.8.6-r2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer-sh/Manifest1
-rw-r--r--media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff84
-rw-r--r--media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild42
3 files changed, 0 insertions, 127 deletions
diff --git a/media-video/mplayer-sh/Manifest b/media-video/mplayer-sh/Manifest
index 53f550554223..f35174f84896 100644
--- a/media-video/mplayer-sh/Manifest
+++ b/media-video/mplayer-sh/Manifest
@@ -1,2 +1 @@
-DIST mplayer.sh-0.8.6.tar.gz 7568 BLAKE2B 4eecf46b75368028f54f090e13575287bbbe9ab6fedaf2def221f539b95fcdd4fba8c3a1ad59d9aca2fd72b6ec770ee159a410383e45d53148d270043fe464c6 SHA512 ff4a11f1b8dae014646f101fcab16d6cebc0c3250bc8d259500c2819b484913270051ed9ec9b1442e647e811030f927db07f71aa64edd6221a875e067e22e36a
DIST mplayer.sh-0.8.7.tar.gz 7851 BLAKE2B b7dbaf93c509a3d2bb38f226dafed2261ddadbff24a6e450f3fe2cf5cb5208bb3e89a1830fc3e59d674e9b045360208e7c221498e32f228be9c6e0147aef2588 SHA512 5e83dd2f83b104f7043d828b713e34f47c9a42a93324424c802d4d448b770e36515accf67bd67ce7461201b5e9cd5596da2bbd182eccef9578c9b31b5fed50d9
diff --git a/media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff b/media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff
deleted file mode 100644
index 3b329215564b..000000000000
--- a/media-video/mplayer-sh/files/mplayer-sh-0.8.6-parameter-aid.diff
+++ /dev/null
@@ -1,84 +0,0 @@
---- mplayer.sh.orig 2006-03-26 23:31:10.000000000 +0200
-+++ mplayer.sh 2006-03-26 23:50:39.000000000 +0200
-@@ -6,6 +6,7 @@
- declare VERSION="0.8.6"
-
- # History (as always in the source code :-)
-+# - add -aid to mplayer when AID is given (Matthias Schwarzott <zzam@gentoo.org>)
- # 0.8.6 - fixed a copy'n'paste bug regarding the subtitle background
- # alpha color (thanks to Christian Haider)
- # - changed the fps values from rational values to integer ones
-@@ -208,6 +209,11 @@
- fi
- debugvar REMOTE "$REMOTE"
-
-+ if test -n "${AID}"; then
-+ AUDIO="-aid ${AID}"
-+ fi
-+ debugvar AUDIO "${AUDIO}"
-+
- if ! test -z "$USERDEF"; then echolog "*** Use Option USERDEF at your own risk!"; fi
- debugvar USERDEF "$USERDEF"
-
-@@ -478,15 +484,24 @@
- declare -i NEW_X NEW_Y
- declare -i HALF_Y FULL_Y
- declare ORIG_FPS NEW_FPS ORIG_ASPECT VIDEO_FORMAT AUDIO_CODEC
--declare CMDLINE AOUT REMOTE USERDEF SUFFIX
-+declare CMDLINE AOUT REMOTE AUDIO USERDEF SUFFIX
- declare FILE="$1"
--declare SLAVE="$2"
-+shift
- declare -a XResPAL[0]
- declare -a XResNTSC[0]
- declare FDSTR=""
- declare SUBTITLES=""
- declare DETC=""
-
-+while [[ -n $1 ]]; do
-+ case ${1} in
-+ SLAVE) SLAVE=SLAVE ;;
-+ AID) AID=${2}; shift ;;
-+ esac
-+
-+ shift
-+done
-+
- echolog "*** Starting mplayer.sh Version $VERSION"
-
- if test -z "$FILE"; then echolog "*** USAGE: mplayer.sh <File_to_be_played>"; exit; fi
-@@ -504,18 +519,18 @@
- if test \( "$FILE" == "$DVDFiles/DVD" -o "$FILE" == "$DVDFiles/VCD" \) -a -n "$DVDFiles" -a -n "$DVD"; then
- if test "$FILE" == "$DVDFiles/DVD"; then
- $USEAC3 && AOUT="$AC3AOUT"
-- CMDLINE="$MPLAYER -vo $VO $AOUT -alang $DVDLANG $DVDOPTIONS $FDSTR $CACHESTR $REMOTE $USERDEF -dvd-device $DVD dvd://"
-+ CMDLINE="$MPLAYER -vo $VO $AOUT -alang $DVDLANG $DVDOPTIONS $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -dvd-device $DVD dvd://"
- fi
- if test "$FILE" == "$DVDFiles/VCD"; then
-- CMDLINE="$MPLAYER -vo $VO $AOUT $VCDOPTIONS $FDSTR $CACHESTR $REMOTE $USERDEF -cdrom-device $DVD vcd://"
-+ CMDLINE="$MPLAYER -vo $VO $AOUT $VCDOPTIONS $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -cdrom-device $DVD vcd://"
- fi
- unset FILE
- elif test "${SUFFIX}" == ".cue"; then
- if $MPLAYER_V1; then
-- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF cue://$FILE:2"
-+ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF cue://$FILE:2"
- unset FILE
- else
-- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF -vcd 2 -cuefile"
-+ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF -vcd 2 -cuefile"
- fi
- else
- # Try to determine the video attributes
-@@ -545,9 +560,9 @@
- \( $NTSC -a $NEW_FPS == "30" -a \( \( $ORIG_X == "352" -a $ORIG_Y == "240" \) -o \( $ORIG_Y == "480" -a \
- \( $ORIG_X == "352" -o $ORIG_X == "480" -o $ORIG_X == "512" -o $ORIG_X == "640" -o $ORIG_X == "704" -o $ORIG_X == "720" \) \) \) \) \
- \) ; then
-- CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $REMOTE $USERDEF"
-+ CMDLINE="$MPLAYER -vo $VO $AOUT $FDSTR $CACHESTR $AUDIO $REMOTE $USERDEF"
- else
-- CMDLINE="$MPLAYER -vo $VO $AOUT -vop $VOP:$NEW_FPS,expand=$NEW_X:$REAL_Y:-1:-1:1,scale=$NEW_X:${NEW_Y}${DETC} $SPEED $FDSTR $CACHESTR $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
-+ CMDLINE="$MPLAYER -vo $VO $AOUT -vop $VOP:$NEW_FPS,expand=$NEW_X:$REAL_Y:-1:-1:1,scale=$NEW_X:${NEW_Y}${DETC} $SPEED $FDSTR $CACHESTR $AUDIO $REMOTE $SUBTITLES $USERDEF $FORCEIDX"
- fi
- fi
-
diff --git a/media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild b/media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild
deleted file mode 100644
index 982453ffa896..000000000000
--- a/media-video/mplayer-sh/mplayer-sh-0.8.6-r2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-RESTRICT="mirror bindist"
-
-inherit epatch
-
-DESCRIPTION="Video Disk Recorder Mplayer API Script"
-HOMEPAGE="http://batleth.sapienti-sat.org/"
-SRC_URI="http://batleth.sapienti-sat.org/projects/VDR/mplayer.sh-${PV}.tar.gz"
-
-KEYWORDS="~amd64 x86"
-SLOT="0"
-LICENSE="all-rights-reserved"
-IUSE=""
-
-RDEPEND=">=media-video/mplayer-0.90_rc4"
-
-S=${WORKDIR}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-parameter-aid.diff"
-
- sed -i "s:^declare CFGFIL.*$:declare CFGFIL=\"\/etc\/vdr\/plugins\/mplayer\/mplayer.sh.conf\":" mplayer.sh
- sed -i mplayer.sh.conf -e "s:^LIRCRC.*$:LIRCRC=\/etc\/lircd.conf:" \
- -e "s:^MPLAYER=.*$:MPLAYER=\/usr\/bin\/mplayer:"
-}
-
-src_install() {
-
- insinto /etc/vdr/plugins/mplayer
- doins mplayer.sh.conf
-
- into /usr/share/vdr/mplayer
- dobin mplayer.sh
-
- dodir /etc/vdr/plugins/DVD-VCD
- touch "${D}"/etc/vdr/plugins/DVD-VCD/{DVD,VCD}
- fowners vdr:video /etc/vdr/plugins/DVD-VCD/{DVD,VCD}
-}