summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-02-04 22:15:03 +0100
committerFabian Groffen <grobian@gentoo.org>2017-02-04 22:15:56 +0100
commite5099643edcd981586507f486a885fd797cd7be3 (patch)
tree47eec102bdca5f823e039c656e68858a72dba721 /net-analyzer/mtr/mtr-9999.ebuild
parentdev-scheme/guile-json: Initial commit (diff)
downloadgentoo-e5099643edcd981586507f486a885fd797cd7be3.tar.gz
gentoo-e5099643edcd981586507f486a885fd797cd7be3.tar.bz2
gentoo-e5099643edcd981586507f486a885fd797cd7be3.zip
net-analyzer/mtr: fix filecaps problem in Prefix, bug #599604
Package-Manager: portage-2.3.3
Diffstat (limited to 'net-analyzer/mtr/mtr-9999.ebuild')
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 797b07c37320..47d97b07432d 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -29,7 +29,7 @@ DEPEND="
"
DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
-FILECAPS=( cap_net_raw /usr/sbin/mtr )
+FILECAPS=( cap_net_raw usr/sbin/mtr )
PATCHES=(
"${FILESDIR}"/${PN}-9999-tinfo.patch
)
@@ -58,3 +58,11 @@ src_configure() {
$(use_with gtk) \
$(use_with ncurses)
}
+
+pkg_postinst() {
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "mtr needs root privileges to run. To grant them:"
+ ewarn " % sudo chown root ${EPREFIX}/usr/sbin/mtr"
+ ewarn " % sudo chmod u+s ${EPREFIX}/usr/sbin/mtr"
+ fi
+}