summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-01-05 21:08:28 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-01-05 21:23:56 +0100
commit060e2e411ddd1311bddf854d50970382a00cc631 (patch)
treee3da24699b18ce7efd4bd283366db4d5a3b8ed13 /net-analyzer/netdata
parentsys-kernel/gentoo-kernel-bin: Bump to 6.6.10 (diff)
downloadgentoo-060e2e411ddd1311bddf854d50970382a00cc631.tar.gz
gentoo-060e2e411ddd1311bddf854d50970382a00cc631.tar.bz2
gentoo-060e2e411ddd1311bddf854d50970382a00cc631.zip
net-analyzer/netdata: advertise net-analyzer/netdata-go-plugin
Bug: https://bugs.gentoo.org/773112 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'net-analyzer/netdata')
-rw-r--r--net-analyzer/netdata/netdata-1.44.0.ebuild4
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild6
2 files changed, 7 insertions, 3 deletions
diff --git a/net-analyzer/netdata/netdata-1.44.0.ebuild b/net-analyzer/netdata/netdata-1.44.0.ebuild
index 6149a81fb3ac..f0470bbdd4ca 100644
--- a/net-analyzer/netdata/netdata-1.44.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.44.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python{3_9,3_10,3_11} )
-inherit autotools fcaps flag-o-matic linux-info python-single-r1 systemd toolchain-funcs
+inherit autotools fcaps flag-o-matic linux-info optfeature python-single-r1 systemd toolchain-funcs
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
@@ -164,4 +164,6 @@ pkg_postinst() {
if use ipmi ; then
fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/freeipmi.plugin'
fi
+
+ optfeature "go.d external plugin" net-analyzer/netdata-go-plugin
}
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 120388949957..9d37063dbfcd 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python{3_9,3_10,3_11} )
-inherit autotools fcaps flag-o-matic linux-info python-single-r1 systemd toolchain-funcs
+inherit autotools fcaps flag-o-matic linux-info optfeature python-single-r1 systemd toolchain-funcs
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/netdata/${PN}.git"
@@ -160,4 +160,6 @@ pkg_postinst() {
if use ipmi ; then
fcaps 'cap_dac_override' 'usr/libexec/netdata/plugins.d/freeipmi.plugin'
fi
+
+ optfeature "go.d external plugin" net-analyzer/netdata-go-plugin
}