summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/tcpslice
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/tcpslice')
-rw-r--r--net-analyzer/tcpslice/Manifest2
-rw-r--r--net-analyzer/tcpslice/files/tcpslice-1.2a_p3-exit.patch10
-rw-r--r--net-analyzer/tcpslice/metadata.xml8
-rw-r--r--net-analyzer/tcpslice/tcpslice-1.2a_p3-r1.ebuild34
4 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/tcpslice/Manifest b/net-analyzer/tcpslice/Manifest
new file mode 100644
index 000000000000..4425fffb629c
--- /dev/null
+++ b/net-analyzer/tcpslice/Manifest
@@ -0,0 +1,2 @@
+DIST tcpslice_1.2a3-4.debian.tar.gz 5784 SHA256 d2b2be807207ff1b268a855a5b4803b2773fdce7749618ac5f4c102195c94db0 SHA512 43a0ad5811c84639be0c6d162ea92101e73240e9689e4b647ee060697382062ec0e22dcb951ca000e05bac829455b7aa37f8dd73c5b1dd87f55e6d61a8a9b59b WHIRLPOOL 223ff2fcfafbaeb3f1bc1088d871a08d5ac7049e39da14ad29d12a43064dcf3c48e187fef14cec003ce1ced659fa65c037f6f3fea5216ac01bb359a3b4599adc
+DIST tcpslice_1.2a3.orig.tar.gz 76879 SHA256 4096e8debc898cfaa16b5306f1c42f8d18b19e30e60da8d4deb781c8f684c840 SHA512 04e12d592807022c78eb4941580ed103995680c69af885bb8f13828a12ec570f7fe93c34c1b20a01d3d99f445d5da17a1fcfbe25b2e3b41abe28304c034654c5 WHIRLPOOL fe151bf832318b29d99a9726a9bda7fc058c38fd83a803f14f2cb38553e4d47862fb7f993bf8c0fb87bf2d95cf91e3dc7e26eb5be9e9b944695d7cbccf54ff74
diff --git a/net-analyzer/tcpslice/files/tcpslice-1.2a_p3-exit.patch b/net-analyzer/tcpslice/files/tcpslice-1.2a_p3-exit.patch
new file mode 100644
index 000000000000..befcfdc9defe
--- /dev/null
+++ b/net-analyzer/tcpslice/files/tcpslice-1.2a_p3-exit.patch
@@ -0,0 +1,10 @@
+--- a/util.c
++++ b/util.c
+@@ -25,6 +25,7 @@
+ #endif
+
+ #include <sys/types.h>
++#include <stdlib.h> /* exit() */
+
+ #include <stdio.h>
+ #if __STDC__
diff --git a/net-analyzer/tcpslice/metadata.xml b/net-analyzer/tcpslice/metadata.xml
new file mode 100644
index 000000000000..1926505a3d61
--- /dev/null
+++ b/net-analyzer/tcpslice/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="github">the-tcpdump-group/tcpslice</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/tcpslice/tcpslice-1.2a_p3-r1.ebuild b/net-analyzer/tcpslice/tcpslice-1.2a_p3-r1.ebuild
new file mode 100644
index 000000000000..4784210e518d
--- /dev/null
+++ b/net-analyzer/tcpslice/tcpslice-1.2a_p3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P="${PN}_${PV/_p/}"
+
+DESCRIPTION="Extract and concatenate portions of pcap files"
+HOMEPAGE="http://www.tcpdump.org/ https://github.com/the-tcpdump-group/tcpslice"
+LICENSE="BSD"
+SLOT="0"
+SRC_URI="mirror://debian/pool/main/t/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/t/${PN}/${MY_P}-4.debian.tar.gz"
+KEYWORDS="~amd64 ~ppc x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P/_/-}"
+
+src_prepare() {
+ epatch \
+ "${WORKDIR}"/debian/patches/[0-]* \
+ "${FILESDIR}"/${P}-exit.patch
+ eautoreconf
+}
+
+src_install() {
+ dosbin tcpslice
+ doman tcpslice.1
+ dodoc README
+}