summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:56:50 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:56:50 +0100
commit07343dd2a03402a9f7ea041f00b2383b7ff7abdb (patch)
treea780d9bb081d2ac5eade2d3575b50a2704486d5a /net-analyzer/zabbix/zabbix-5.0.9.ebuild
parentnet-analyzer/vnstat: migrate to tmpfiles.eclass (diff)
downloadgentoo-07343dd2a03402a9f7ea041f00b2383b7ff7abdb.tar.gz
gentoo-07343dd2a03402a9f7ea041f00b2383b7ff7abdb.tar.bz2
gentoo-07343dd2a03402a9f7ea041f00b2383b7ff7abdb.zip
net-analyzer/zabbix: migrate to tmpfiles.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/zabbix/zabbix-5.0.9.ebuild')
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.9.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-analyzer/zabbix/zabbix-5.0.9.ebuild b/net-analyzer/zabbix/zabbix-5.0.9.ebuild
index 37470326b6db..87ea6afce12a 100644
--- a/net-analyzer/zabbix/zabbix-5.0.9.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.9.ebuild
@@ -5,7 +5,7 @@ EAPI=7
# needed to make webapp-config dep optional
WEBAPP_OPTIONAL="yes"
-inherit flag-o-matic webapp java-pkg-opt-2 systemd toolchain-funcs
+inherit flag-o-matic webapp java-pkg-opt-2 systemd toolchain-funcs tmpfiles
DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers"
HOMEPAGE="https://www.zabbix.com/"
@@ -187,7 +187,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-server.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
+ newtmpfiles "${FILESDIR}"/zabbix-server.tmpfiles zabbix-server.conf
fi
if use proxy; then
@@ -204,7 +204,7 @@ src_install() {
doins -r "${S}"/database/
systemd_dounit "${FILESDIR}"/zabbix-proxy.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
+ newtmpfiles "${FILESDIR}"/zabbix-proxy.tmpfiles zabbix-proxy.conf
fi
if use agent; then
@@ -221,7 +221,7 @@ src_install() {
src/zabbix_get/zabbix_get
systemd_dounit "${FILESDIR}"/zabbix-agentd.service
- systemd_newtmpfilesd "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
+ newtmpfiles "${FILESDIR}"/zabbix-agentd.tmpfiles zabbix-agentd.conf
fi
fowners root:zabbix /etc/zabbix