summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-02-21 22:22:09 +0100
committerMichał Górny <mgorny@gentoo.org>2019-04-21 14:37:34 +0200
commite14bfd440f7a9e5a57540879580e87032813e64f (patch)
tree60a2286470b9c4a8cd7ecdc49a95f5ff4bbac219 /net-dns/dnssec-validator/dnssec-validator-2.2.3.ebuild
parentdev-util/creduce: Bump to 2.8.0 (diff)
downloadgentoo-e14bfd440f7a9e5a57540879580e87032813e64f.tar.gz
gentoo-e14bfd440f7a9e5a57540879580e87032813e64f.tar.bz2
gentoo-e14bfd440f7a9e5a57540879580e87032813e64f.zip
net-dns/dnssec-validator: bump to version 2.2.3
The old dnsval package seems to be removed by upstream, as it has been integrated into the dnssec-tools package. This version needs support for openssl-1.1. Closes: https://bugs.gentoo.org/641552 Closes: https://bugs.gentoo.org/672494 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/10597 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-dns/dnssec-validator/dnssec-validator-2.2.3.ebuild')
-rw-r--r--net-dns/dnssec-validator/dnssec-validator-2.2.3.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-dns/dnssec-validator/dnssec-validator-2.2.3.ebuild b/net-dns/dnssec-validator/dnssec-validator-2.2.3.ebuild
new file mode 100644
index 000000000000..04606f66a6fb
--- /dev/null
+++ b/net-dns/dnssec-validator/dnssec-validator-2.2.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tools to ease the validation of DNSSEC related technologies"
+HOMEPAGE="https://www.dnssec-tools.org/"
+SRC_URI="https://github.com/DNSSEC-Tools/DNSSEC-Tools/archive/dnssec-tools-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dlv +ipv6 +nsec3 static-libs +threads"
+
+RDEPEND=">=dev-libs/openssl-1.1.0:0"
+DEPEND="${RDEPEND}"
+
+# Tests fail due "Cannot create context: -7"
+RESTRICT="test"
+
+S="${WORKDIR}/DNSSEC-Tools-dnssec-tools-${PV}/dnssec-tools/validator"
+
+PATCHES=(
+ # Users LDFLAGS are not respected
+ # See https://github.com/DNSSEC-Tools/DNSSEC-Tools/pull/9
+ "${FILESDIR}/${P}-ldflags.patch"
+)
+
+src_prepare() {
+ default
+
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with dlv)
+ $(use_with ipv6)
+ $(use_with nsec3)
+ $(use_enable static-libs static)
+ $(use_with threads)
+ --with-dnsval-conf="${EPREFIX%/}/etc/dnssec-tools/dnsval.conf"
+ --with-resolv-conf="${EPREFIX%/}/etc/dnssec-tools/resolv.conf"
+ --with-root-hints="${EPREFIX%/}/etc/dnssec-tools/root.hints"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ # Install fails with MAKEOPTS > -j1
+ # See https://github.com/DNSSEC-Tools/DNSSEC-Tools/issues/8
+ emake -j1 DESTDIR="${D}" install
+
+ einstalldocs
+
+ find "${D}" -name '*.la' -delete || die
+}