summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2022-02-24 09:20:32 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-02-24 09:20:51 -0800
commit63428e7ae12c38a6c101386f7cf0499cfb087f04 (patch)
tree9eac0c067c5e4cd170dc97c9c32058187195628c /net-firewall/nftables/files
parentprofiles: last-rite dev-python/socketpool (diff)
downloadgentoo-63428e7ae12c38a6c101386f7cf0499cfb087f04.tar.gz
gentoo-63428e7ae12c38a6c101386f7cf0499cfb087f04.tar.bz2
gentoo-63428e7ae12c38a6c101386f7cf0499cfb087f04.zip
net-firewall/nftables: Version bump to 1.0.2
Had to drop the slibtool patch as it causes build to fail with GNU libtool. Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'net-firewall/nftables/files')
-rw-r--r--net-firewall/nftables/files/nftables-1.0.2-compilation.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-firewall/nftables/files/nftables-1.0.2-compilation.patch b/net-firewall/nftables/files/nftables-1.0.2-compilation.patch
new file mode 100644
index 000000000000..166063587485
--- /dev/null
+++ b/net-firewall/nftables/files/nftables-1.0.2-compilation.patch
@@ -0,0 +1,34 @@
+From 18a08fb7f0443f8bde83393bd6f69e23a04246b3 Mon Sep 17 00:00:00 2001
+From: Pablo Neira Ayuso <pablo@netfilter.org>
+Date: Tue, 22 Feb 2022 00:56:36 +0100
+Subject: examples: compile with `make check' and add AM_CPPFLAGS
+
+Compile examples via `make check' like libnftnl does. Use AM_CPPFLAGS to
+specify local headers via -I.
+
+Unfortunately, `make distcheck' did not catch this compile time error in
+my system, since it was using the nftables/libnftables.h file of the
+previous nftables release.
+
+Fixes: 5b364657a35f ("build: missing SUBIRS update")
+Fixes: caf2a6ad2d22 ("examples: add libnftables example program")
+Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
+---
+ examples/Makefile.am | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index c972170d..3b8b0b67 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -1,4 +1,6 @@
+-noinst_PROGRAMS = nft-buffer \
++check_PROGRAMS = nft-buffer \
+ nft-json-file
+
++AM_CPPFLAGS = -I$(top_srcdir)/include
++
+ LDADD = $(top_builddir)/src/libnftables.la
+--
+cgit v1.2.3
+