summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/qutim/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/qutim/files')
-rw-r--r--net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch25
-rw-r--r--net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch151
2 files changed, 176 insertions, 0 deletions
diff --git a/net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch b/net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch
new file mode 100644
index 000000000000..f32379662417
--- /dev/null
+++ b/net-im/qutim/files/qutim-0.3.1-cmake-2.8.12-kde-build.patch
@@ -0,0 +1,25 @@
+From 984d4af9568de9c54a44e4cf96cca76e0cea256a Mon Sep 17 00:00:00 2001
+From: Ruslan Nigmatullin <euroelessar@yandex.ru>
+Date: Mon, 24 Feb 2014 18:09:20 +0300
+Subject: [PATCH 2/2] Fixed compilation with the newest cmake
+
+---
+ plugins/kdeintegration/CMakeLists.txt | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/plugins/kdeintegration/CMakeLists.txt b/plugins/kdeintegration/CMakeLists.txt
+index 6f1a9f8..805ad80 100644
+--- a/plugins/kdeintegration/CMakeLists.txt
++++ b/plugins/kdeintegration/CMakeLists.txt
+@@ -8,6 +8,8 @@ endif()
+
+ include(KDE4Defaults)
+
++set(CMAKE_AUTOMOC true)
++
+ add_definitions( ${KDE4_DEFINITIONS} )
+
+ qutim_add_plugin(kdeintegration
+--
+2.0.4
+
diff --git a/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch b/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch
new file mode 100644
index 000000000000..dd1aba82891c
--- /dev/null
+++ b/net-im/qutim/files/qutim-0.3.2-astral-migrate-qt-telepaphy.patch
@@ -0,0 +1,151 @@
+From bb8654db870d983d5b6558d9f16b22f443315eaf Mon Sep 17 00:00:00 2001
+From: Alexander Golubev <fatzer2@gmail.com>
+Date: Mon, 3 Nov 2014 16:30:27 +0300
+Subject: [PATCH 3/3] protocol/astral: migrate to qt-telepaphy API v0.9
+
+---
+ protocols/astral/src/astralaccount.cpp | 12 ++++++------
+ protocols/astral/src/astralaccount.h | 14 +++++++-------
+ protocols/astral/src/astralcontact.h | 6 +++---
+ protocols/astral/src/astralplugin.cpp | 6 +++---
+ protocols/astral/src/astralroster.cpp | 14 +++++++-------
+ protocols/astral/src/astralsession.h | 4 ++--
+ 6 files changed, 28 insertions(+), 28 deletions(-)
+
+diff --git a/protocols/astral/src/astralaccount.cpp b/protocols/astral/src/astralaccount.cpp
+index 1d51707..e9bf729 100644
+--- a/protocols/astral/src/astralaccount.cpp
++++ b/protocols/astral/src/astralaccount.cpp
+@@ -26,9 +26,9 @@
+ #include "astralprotocol.h"
+ #include "astralroster.h"
+ #include "astralsessionmanager.h"
+-#include <TelepathyQt4/Account>
+-#include <TelepathyQt4/AccountManager>
+-#include <TelepathyQt4/PendingChannel>
++#include <TelepathyQt/Account>
++#include <TelepathyQt/AccountManager>
++#include <TelepathyQt/PendingChannel>
+ #include <QDebug>
+
+ struct AstralAccountPrivate
+@@ -146,14 +146,14 @@ void AstralAccount::onNewChannels(const Tp::ChannelDetailsList &channels)
+ qDebug() << "AstralAccount::onNewChannels";
+ foreach (const Tp::ChannelDetails &details, channels)
+ {
+- QString channelType = details.properties.value(QLatin1String(TELEPATHY_INTERFACE_CHANNEL ".ChannelType")).toString();
+- bool requested = details.properties.value(QLatin1String(TELEPATHY_INTERFACE_CHANNEL ".Requested")).toBool();
++ QString channelType = details.properties.value(TP_QT_IFACE_CHANNEL + QLatin1String(".ChannelType")).toString();
++ bool requested = details.properties.value(TP_QT_IFACE_CHANNEL + QLatin1String(".Requested")).toBool();
+ qDebug() << " channelType:" << channelType;
+ qDebug() << " requested :" << requested;
+ qDebug() << " channelPath:" << details.channel.path();
+ qDebug() << " properties :" << details.properties;
+
+- if (channelType == TELEPATHY_INTERFACE_CHANNEL_TYPE_TEXT && !requested)
++ if (channelType == TP_QT_IFACE_CHANNEL_TYPE_TEXT && !requested)
+ {
+ TextChannelPtr channel = TextChannel::create(p->conn,
+ details.channel.path(),
+diff --git a/protocols/astral/src/astralaccount.h b/protocols/astral/src/astralaccount.h
+index 2781fb9..6e4378d 100644
+--- a/protocols/astral/src/astralaccount.h
++++ b/protocols/astral/src/astralaccount.h
+@@ -26,13 +26,13 @@
+ #define ASTRALACCOUNT_H
+
+ #include <qutim/account.h>
+-#include <TelepathyQt4/ConnectionManager>
+-#include <TelepathyQt4/Connection>
+-#include <TelepathyQt4/TextChannel>
+-#include <TelepathyQt4/AccountManager>
+-#include <TelepathyQt4/PendingConnection>
+-#include <TelepathyQt4/PendingOperation>
+-#include <TelepathyQt4/PendingReady>
++#include <TelepathyQt/ConnectionManager>
++#include <TelepathyQt/Connection>
++#include <TelepathyQt/TextChannel>
++#include <TelepathyQt/AccountManager>
++#include <TelepathyQt/PendingConnection>
++#include <TelepathyQt/PendingOperation>
++#include <TelepathyQt/PendingReady>
+
+ #include "astralroster.h"
+
+diff --git a/protocols/astral/src/astralcontact.h b/protocols/astral/src/astralcontact.h
+index ce0e9dd..5adfb07 100644
+--- a/protocols/astral/src/astralcontact.h
++++ b/protocols/astral/src/astralcontact.h
+@@ -26,9 +26,9 @@
+ #define ASTRALCONTACT_H
+
+ #include <qutim/contact.h>
+-#include <TelepathyQt4/Types>
+-#include <TelepathyQt4/Contact>
+-#include <TelepathyQt4/Connection>
++#include <TelepathyQt/Types>
++#include <TelepathyQt/Contact>
++#include <TelepathyQt/Connection>
+
+ using namespace Tp;
+ using namespace qutim_sdk_0_3;
+diff --git a/protocols/astral/src/astralplugin.cpp b/protocols/astral/src/astralplugin.cpp
+index e907866..d79642e 100644
+--- a/protocols/astral/src/astralplugin.cpp
++++ b/protocols/astral/src/astralplugin.cpp
+@@ -24,9 +24,9 @@
+ ****************************************************************************/
+ #include "astralplugin.h"
+ #include <QtCore/QtDebug>
+-#include <TelepathyQt4/Debug>
+-#include <TelepathyQt4/Constants>
+-#include <TelepathyQt4/Types>
++#include <TelepathyQt/Debug>
++#include <TelepathyQt/Constants>
++#include <TelepathyQt/Types>
+ //#include <TelepathyQt4/ConnectionInterfaceAvatarsInterface>
+
+ AstralPlugin::AstralPlugin()
+diff --git a/protocols/astral/src/astralroster.cpp b/protocols/astral/src/astralroster.cpp
+index 9eb209f..588cc55 100644
+--- a/protocols/astral/src/astralroster.cpp
++++ b/protocols/astral/src/astralroster.cpp
+@@ -24,13 +24,13 @@
+ ****************************************************************************/
+ #include "astralroster.h"
+ #include "astralaccount.h"
+-#include <TelepathyQt4/Types>
+-#include <TelepathyQt4/Contact>
+-#include <TelepathyQt4/ContactManager>
+-#include <TelepathyQt4/PendingConnection>
+-#include <TelepathyQt4/PendingContacts>
+-#include <TelepathyQt4/PendingOperation>
+-#include <TelepathyQt4/PendingReady>
++#include <TelepathyQt/Types>
++#include <TelepathyQt/Contact>
++#include <TelepathyQt/ContactManager>
++#include <TelepathyQt/PendingConnection>
++#include <TelepathyQt/PendingContacts>
++#include <TelepathyQt/PendingOperation>
++#include <TelepathyQt/PendingReady>
+
+ struct AstralRosterPrivate
+ {
+diff --git a/protocols/astral/src/astralsession.h b/protocols/astral/src/astralsession.h
+index fa78e45..a5dd1c3 100644
+--- a/protocols/astral/src/astralsession.h
++++ b/protocols/astral/src/astralsession.h
+@@ -26,8 +26,8 @@
+ #define ASTRALSESSION_H
+
+ #include <qutim/chatunit.h>
+-#include <TelepathyQt4/TextChannel>
+-#include <TelepathyQt4/Message>
++#include <TelepathyQt/TextChannel>
++#include <TelepathyQt/Message>
+
+ using namespace qutim_sdk_0_3;
+ using namespace Tp;
+--
+2.0.4
+