summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-28 12:40:57 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-28 12:53:09 +0100
commit0a0f328f896c6dcaab28fa11f9f358dc3ec839e4 (patch)
tree07fb3bc5828c3fbe93b5a880a909f7a14053445a /net-libs/nDPI
parentwww-client/opera-developer: Version 68.0.3581.0 (diff)
downloadgentoo-0a0f328f896c6dcaab28fa11f9f358dc3ec839e4.tar.gz
gentoo-0a0f328f896c6dcaab28fa11f9f358dc3ec839e4.tar.bz2
gentoo-0a0f328f896c6dcaab28fa11f9f358dc3ec839e4.zip
net-libs/nDPI: Hack around PACKAGE* autoheader definitions
autogen.sh patches the autogenerated configure script to hide the PACKAGE* variables from ndpi_config.h, and so should we. Package-Manager: Portage-2.3.85, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=704074 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/nDPI')
-rw-r--r--net-libs/nDPI/nDPI-3.0-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/nDPI/nDPI-3.0-r2.ebuild b/net-libs/nDPI/nDPI-3.0-r2.ebuild
new file mode 100644
index 000000000000..50396b2d9db3
--- /dev/null
+++ b/net-libs/nDPI/nDPI-3.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools multilib
+
+DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="
+ dev-libs/json-c:=
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ # Taken from autogen.sh (bug #704074):
+ sed \
+ -e "s/@NDPI_MAJOR@/$(ver_cut 1)/g" \
+ -e "s/@NDPI_MINOR@/$(ver_cut 2)/g" \
+ -e "s/@NDPI_PATCH@/$(ver_cut 3)/g" \
+ -e "s/@NDPI_VERSION_SHORT@/${PV}/g" \
+ < "${S}/configure.seed" \
+ > "${S}/configure.ac" || die
+
+ sed -i \
+ -e "s%^libdir\s*=\s*\${prefix}/lib\s*$%libdir = \${prefix}/$(get_libdir)%" \
+ src/lib/Makefile.in || die
+
+ default
+ eautoreconf
+
+ # Taken from autogen.sh (bug #704074):
+ sed -i \
+ -e "s/#define PACKAGE/#define NDPI_PACKAGE/g" \
+ -e "s/#define VERSION/#define NDPI_VERSION/g" \
+ configure || die
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm "${D}"/usr/$(get_libdir)/lib${PN,,}.a || die
+ fi
+}