summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-08-14 14:13:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-08-14 15:35:46 +0200
commitf00f5a104b330be74d5961d84cdae7cbc09de9ff (patch)
tree3c1f3352aa15c8d0261576265b12976ee1f7afee /net-libs/rpc2/rpc2-2.14.ebuild
parentsys-apps/rng-tools: Removed old. (diff)
downloadgentoo-f00f5a104b330be74d5961d84cdae7cbc09de9ff.tar.gz
gentoo-f00f5a104b330be74d5961d84cdae7cbc09de9ff.tar.bz2
gentoo-f00f5a104b330be74d5961d84cdae7cbc09de9ff.zip
net-libs/rpc2: Bump to version 2.14
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'net-libs/rpc2/rpc2-2.14.ebuild')
-rw-r--r--net-libs/rpc2/rpc2-2.14.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/rpc2/rpc2-2.14.ebuild b/net-libs/rpc2/rpc2-2.14.ebuild
new file mode 100644
index 000000000000..baa5a0fa5694
--- /dev/null
+++ b/net-libs/rpc2/rpc2-2.14.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Remote procedure call package for IP/UDP (used by Coda)"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/rpc2/src/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/lwp-2.5"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc README.ipv6
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}