summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-29 23:00:53 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-30 00:24:43 +0200
commit4e70ba7a532946db144995ca1b5d1a3bffda9955 (patch)
tree1dcb49cc31439f2a3559718df5ff9071a1be47f6 /net-libs/signon-oauth2/signon-oauth2-0.24.ebuild
parentmedia-gfx/yafaray: Create 3.3.0 ebuild. (diff)
downloadgentoo-4e70ba7a532946db144995ca1b5d1a3bffda9955.tar.gz
gentoo-4e70ba7a532946db144995ca1b5d1a3bffda9955.tar.bz2
gentoo-4e70ba7a532946db144995ca1b5d1a3bffda9955.zip
net-libs/signon-oauth2: 0.24 version bump, disable examples
Reported-by: Matija Skala <mskala@gmx.com> Closes: https://github.com/gentoo/gentoo/pull/8579 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-libs/signon-oauth2/signon-oauth2-0.24.ebuild')
-rw-r--r--net-libs/signon-oauth2/signon-oauth2-0.24.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/signon-oauth2/signon-oauth2-0.24.ebuild b/net-libs/signon-oauth2/signon-oauth2-0.24.ebuild
new file mode 100644
index 000000000000..ea3dd0c41f71
--- /dev/null
+++ b/net-libs/signon-oauth2/signon-oauth2-0.24.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=signon-plugin-oauth2
+MY_PV=VERSION_${PV}
+inherit qmake-utils
+
+DESCRIPTION="OAuth2 plugin for Signon daemon"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/${MY_PN}/-/archive/${MY_PV}/${MY_PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-disable-examples.patch"
+ "${FILESDIR}/${P}-dont-install-tests.patch"
+)
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e '/^SUBDIRS/s/tests//' signon-oauth2.pro || die "Failed to disable tests"
+ fi
+}
+
+src_configure() {
+ eqmake5 \
+ LIBDIR=/usr/$(get_libdir)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}