summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-08 00:02:55 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-08 00:05:57 +0200
commitaf1aa5dda0985512c063560717852166af82e144 (patch)
tree9f939fe54ac3269767e7568f61728412305ecb1f /net-libs
parentnet-analyzer/nload: QA fix, shorten DESCRIPTION (diff)
downloadgentoo-af1aa5dda0985512c063560717852166af82e144.tar.gz
gentoo-af1aa5dda0985512c063560717852166af82e144.tar.bz2
gentoo-af1aa5dda0985512c063560717852166af82e144.zip
net-libs/zeromq: bump to v4.3.3
Bug: https://bugs.gentoo.org/740574 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/zeromq/Manifest1
-rw-r--r--net-libs/zeromq/zeromq-4.3.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/zeromq/Manifest b/net-libs/zeromq/Manifest
index 822566c78516..592bf7febdd2 100644
--- a/net-libs/zeromq/Manifest
+++ b/net-libs/zeromq/Manifest
@@ -1,3 +1,4 @@
DIST zeromq-2.2.0.tar.gz 1899104 BLAKE2B 1c02629e33151db11c529d538ce519dae7f3426ee13f8a2b840960779cd7514f7cc3257983704f2c392a00ad62f4a955bc33fcbdadb8bada3858753a1790ab41 SHA512 fb3cf421b2dc48c31956b3e3ee4ab6ebc743deec3bf626c2238a1996c8c51be87260bd6aa662793a1f0c34dcda9b3146763777bb162dfad6fec4ca7acc403b2e
DIST zeromq-3.2.5.tar.gz 2082960 BLAKE2B 88fe3b3206f0e59acb3cf370964c9e40df2dceb5e40aef85ae8cd8fedef4c655fd2698a7f81431e34550b5156814a75c0b1a738393e7c44acbfefe96acc4c4bc SHA512 3682204e5a47824d149968e62fbf9768134370e4f7debbbf8f2bfa24bdd0a781e50c4a9b4231af8a0c4bab61839169100525a91472448ef180a9672342e10a3f
DIST zeromq-4.3.2.tar.gz 1697442 BLAKE2B 70a1f6da357987c32483050fcf86cb81a1fb0b65a527f6900f54eea8958c6aa6024af04067114663824d42305f507cba67e03c7aaab7e23e4f6332d4368613eb SHA512 b6251641e884181db9e6b0b705cced7ea4038d404bdae812ff47bdd0eed12510b6af6846b85cb96898e253ccbac71eca7fe588673300ddb9c3109c973250c8e4
+DIST zeromq-4.3.3.tar.gz 2117050 BLAKE2B 69bd1544fa76232ecf860b364592762c4170c327c444bf79a916947e1c370eb8c6c20b2ae271374d70bde11db9116ef6a64262e287982e5f41d6a5029649348f SHA512 4c18d784085179c5b1fcb753a93813095a12c8d34970f2e1bfca6499be6c9d67769c71c68b7ca54ff181b20390043170e89733c22f76ff1ea46494814f7095b1
diff --git a/net-libs/zeromq/zeromq-4.3.3.ebuild b/net-libs/zeromq/zeromq-4.3.3.ebuild
new file mode 100644
index 000000000000..e9a0a3255f32
--- /dev/null
+++ b/net-libs/zeromq/zeromq-4.3.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="A brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="https://github.com/zeromq/libzmq/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc drafts pgm +sodium static-libs test unwind elibc_Darwin"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !elibc_Darwin? ( unwind? ( sys-libs/libunwind ) )
+ sodium? ( dev-libs/libsodium:= )
+ pgm? ( ~net-libs/openpgm-5.2.122 )"
+DEPEND="${RDEPEND}
+ !elibc_Darwin? ( sys-apps/util-linux )
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ pgm? ( virtual/pkgconfig )"
+
+src_prepare() {
+ sed \
+ -e '/libzmq_werror=/s:yes:no:g' \
+ -i configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable drafts)
+ $(use_enable static-libs static)
+ $(use_enable unwind libunwind)
+ $(use_with sodium libsodium)
+ $(use_with pgm)
+ $(use_with doc docs)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # Restricting to one job because multiple tests are using the same port.
+ # Upstream knows the problem and says it doesn't support parallel test
+ # execution, see ${S}/INSTALL.
+ emake -j1 check
+}
+
+src_install() {
+ default
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
+}