summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-28 17:16:30 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-28 17:49:04 +0200
commite5f718f3d106f666f5fb8c01cfc77c440ca64067 (patch)
tree253adc1828ba1acdc64ccf4efa8f597f1111ea79 /net-libs
parentnet-libs/gupnp: Drop old (diff)
downloadgentoo-e5f718f3d106f666f5fb8c01cfc77c440ca64067.tar.gz
gentoo-e5f718f3d106f666f5fb8c01cfc77c440ca64067.tar.bz2
gentoo-e5f718f3d106f666f5fb8c01cfc77c440ca64067.zip
net-libs/gupnp: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gupnp/Manifest1
-rw-r--r--net-libs/gupnp/gupnp-0.20.17.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-libs/gupnp/Manifest b/net-libs/gupnp/Manifest
index 1b57bc36d74b..9f0b44422473 100644
--- a/net-libs/gupnp/Manifest
+++ b/net-libs/gupnp/Manifest
@@ -1 +1,2 @@
DIST gupnp-0.20.16.tar.xz 406912 SHA256 ff1119eff12529c46837e03c742f69dc4fae48d59097d79582d38a383b832602 SHA512 3db3b72a4e5eed6c7910eba4f27e7acacc21d4b4c63488dc3a0328a7a8ab4082fad203bd67923fc35cb6475a4bc918ca95cb50a6eb6ac8e1c6e88e969d9549f7 WHIRLPOOL 1f46ed6dd5725720ce6c6617d712552ec7dac05f0e75e5cf7d3d99a82299427cacb1d4b807e6149a3b9b7ea489233cf7cb299528108b80b3c8ff0210533d27e0
+DIST gupnp-0.20.17.tar.xz 409184 SHA256 c9e415db749e75d82b17de341e6430ebce2a7ce457640c039cfcb03b498a8fd2 SHA512 2f78036a09db2e8aacab4cf34851c26cd350343efaf294a032ec348561186e6805457fc6ea5f79bf438cf44331d997a0e154edd1bce30d6712974f170cad676c WHIRLPOOL 8c55f1a692847a8f6d92d1eb99fb628856e6663c11cb675f7b3c2c2a2c3f4f8b031796c4368c9d8aada5c4056be59e33ff04aa66297d368bc549ce26b871065e
diff --git a/net-libs/gupnp/gupnp-0.20.17.ebuild b/net-libs/gupnp/gupnp-0.20.17.ebuild
new file mode 100644
index 000000000000..6c31a9637538
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.20.17.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+# FIXME: Claims to works with python3 but appears to be wishful thinking
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 multilib-minimal python-r1 vala
+
+DESCRIPTION="An object-oriented framework for creating UPnP devs and control points"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="connman +introspection kernel_linux networkmanager"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( connman networkmanager )
+"
+
+# prefix: uuid dependency can be adapted to non-linux platforms
+RDEPEND="${PYTHON_DEPS}
+ >=net-libs/gssdp-0.14.15:0=[introspection?,${MULTILIB_USEDEP}]
+ >=net-libs/libsoup-2.48.0:2.4[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ >=sys-apps/util-linux-2.24.1-r3[${MULTILIB_USEDEP}]
+ introspection? (
+ >=dev-libs/gobject-introspection-1.36:=
+ $(vala_depend) )
+ connman? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ networkmanager? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ !net-libs/gupnp-vala
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ sys-devel/gettext
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local backend=unix
+ use kernel_linux && backend=linux
+ use connman && backend=connman
+ use networkmanager && backend=network-manager
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(multilib_native_use_enable introspection) \
+ --disable-static \
+ --with-context-manager=${backend}
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ python_foreach_impl python_doscript tools/gupnp-binding-tool
+}