summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2020-12-18 19:30:21 +0100
committerSam James <sam@gentoo.org>2020-12-29 21:09:26 +0000
commitb51bfc358e51ef4ddb46da498a2f0691873926ea (patch)
tree1be1007a96d75d9018085b1cf69b82b9613c1103 /net-mail/automx2
parentdev-libs/uthash: minor changes post-merge (diff)
downloadgentoo-b51bfc358e51ef4ddb46da498a2f0691873926ea.tar.gz
gentoo-b51bfc358e51ef4ddb46da498a2f0691873926ea.tar.bz2
gentoo-b51bfc358e51ef4ddb46da498a2f0691873926ea.zip
net-mail/automx2: Bump to version 2020.2
Feature release 2020.2 introduces support for POP3 servers. Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/automx2')
-rw-r--r--net-mail/automx2/Manifest1
-rw-r--r--net-mail/automx2/automx2-2020.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-mail/automx2/Manifest b/net-mail/automx2/Manifest
index a8ac298f32c7..39ebb80d49d1 100644
--- a/net-mail/automx2/Manifest
+++ b/net-mail/automx2/Manifest
@@ -1,2 +1,3 @@
DIST automx2-2019.0.tar.bz2 46670 BLAKE2B 6f62b4429be8046fce18ccba6827879a99627d8fbe9cf7973d8059e87b4968a280b62d5d005aaed3b0e1074053f4a6355c34f2cdce2f06a9afb14c52b4504fb7 SHA512 e494a48ffd3e6d133a89db5afd1dc75116a8efcc41f0571a24271bcbe6074c86d62184ce00bae9ced888a70be7d20f2a3614f28007d4481537d42c680dca4daa
DIST automx2-2020.1.tar.bz2 49405 BLAKE2B 2c9b26300e32e613f622e0b3a39b7f408d22e22638d61da3c93f5d448fe3ebb325e9a0004e3351abed2c9e427373c42637e3539831c04cda8e65a4d1bba1773e SHA512 823e569eacedcf49d53f8ed623a75455e715e3d49186179927a0e10d3efe9823c336912789bbf3d7d2f9aba3053b601352c99bda4ffcc9a7b78e412c938cd91f
+DIST automx2-2020.2.tar.bz2 50740 BLAKE2B 394d26a06d23efe18a3c147f89660a9dbdde7edba078fd361f188738fdc28d36122aa8182e965bb8e3d69d4cbcd3cb784bc7722dd382d1fbee36213459b91fa1 SHA512 dce790c754fd089a15d0baf023a9cb2e04ebb42a4558fc91b06c2de2105f3e00f3675a555739ff1bc35166c98f6cecec62c95f18f4144e88ac6024eaa6f39abe
diff --git a/net-mail/automx2/automx2-2020.2.ebuild b/net-mail/automx2/automx2-2020.2.ebuild
new file mode 100644
index 000000000000..27bbeeef2a14
--- /dev/null
+++ b/net-mail/automx2/automx2-2020.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://automx.org/"
+SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+BDEPEND="acct-user/automx2
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export AUTOMX2_CONF="tests/unittest.conf"
+ ${EPYTHON} -m unittest discover tests/ || die
+}
+
+python_install_all() {
+ if use doc; then
+ DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
+ HTML_DOCS="doc/*.html doc/*.svg"
+ fi
+ sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
+ newconfd "${FILESDIR}/confd" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}