summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2025-01-01 22:08:43 +0100
committerThomas Raschbacher <lordvan@gentoo.org>2025-01-01 22:09:52 +0100
commit36ea1618c15b25aa51d876b1dfb7aecf8ce6a6c8 (patch)
tree8b1638f5bd21cc66877f05bad2fee9e38097ab9b /net-mail
parentnet-mail/stalwart-cli: fix warnings (diff)
downloadgentoo-36ea1618c15b25aa51d876b1dfb7aecf8ce6a6c8.tar.gz
gentoo-36ea1618c15b25aa51d876b1dfb7aecf8ce6a6c8.tar.bz2
gentoo-36ea1618c15b25aa51d876b1dfb7aecf8ce6a6c8.zip
net-mail/stalwart-mail: fix warnings
Signed-off-by: Thomas Raschbacher <lordvan@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/stalwart-mail/metadata.xml3
-rw-r--r--net-mail/stalwart-mail/stalwart-mail-0.10.7.ebuild16
2 files changed, 11 insertions, 8 deletions
diff --git a/net-mail/stalwart-mail/metadata.xml b/net-mail/stalwart-mail/metadata.xml
index d5549a5afdb7..90e605af1ee8 100644
--- a/net-mail/stalwart-mail/metadata.xml
+++ b/net-mail/stalwart-mail/metadata.xml
@@ -8,4 +8,7 @@
<use>
<flag name="rocks">Enables rocksdb storage backend</flag>
</use>
+ <upstream>
+ <remote-id type="github">stalwartlabs/mail-server</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/net-mail/stalwart-mail/stalwart-mail-0.10.7.ebuild b/net-mail/stalwart-mail/stalwart-mail-0.10.7.ebuild
index 044e50b3e693..e3a343d11b08 100644
--- a/net-mail/stalwart-mail/stalwart-mail-0.10.7.ebuild
+++ b/net-mail/stalwart-mail/stalwart-mail-0.10.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2024 Gentoo Authors
+# Copyright 2024-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Autogenerated by pycargoebuild 0.13.4
@@ -745,28 +745,28 @@ SRC_URI="https://github.com/stalwartlabs/mail-server/archive/refs/tags/v${PV}.ta
${CARGO_CRATE_URIS}
"
+S="${WORKDIR}/mail-server-${PV}"
+
LICENSE="|| ( AGPL-3 )"
# Dependent crate licenses
LICENSE+="
AGPL-3 Apache-2.0 BSD-2 BSD Boost-1.0 CC0-1.0 ISC LGPL-2+ MIT
MPL-2.0 Unicode-3.0 ZLIB
"
-SLOT="0"
-KEYWORDS="~amd64"
-
-IUSE="sqlite postgres mysql +rocks"
RDEPEND="acct-group/stalwart-mail
acct-user/stalwart-mail"
-S="${WORKDIR}/mail-server-${PV}"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sqlite postgres mysql +rocks"
DOCS="resources/config README.md SECURITY.md UPGRADING.md CONTRIBUTING.md CHANGELOG.md"
src_unpack() {
cargo_src_unpack
- sed -i -e "s%__PATH__/etc/%${ROOT}/opt/stalwart-mail/etc/%g" "${S}"/resources/systemd/stalwart-mail.service || die
- sed -i -e "s%__PATH__/bin/%${ROOT}/usr/bin/%g" "${S}"/resources/systemd/stalwart-mail.service || die
+ sed -i -e "s%__PATH__/etc/%/opt/stalwart-mail/etc/%g" "${S}"/resources/systemd/stalwart-mail.service || die
+ sed -i -e "s%__PATH__/bin/%/usr/bin/%g" "${S}"/resources/systemd/stalwart-mail.service || die
}
src_configure() {