summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2018-06-08 14:03:25 +0100
committerTony Vroon <chainsaw@gentoo.org>2018-06-08 14:03:37 +0100
commitced556648fe3eeecc86bd8b50d26dce1e098a009 (patch)
treef50cb994abfba1333131bd67eb20e4bbb4d57a5b /net-misc/bird
parentsci-chemistry/modeller: Import from science overlay (diff)
downloadgentoo-ced556648fe3eeecc86bd8b50d26dce1e098a009.tar.gz
gentoo-ced556648fe3eeecc86bd8b50d26dce1e098a009.tar.bz2
gentoo-ced556648fe3eeecc86bd8b50d26dce1e098a009.zip
net-misc/bird: 1.6.4 & 2.0.2 version bumps
As requested by Luis Ressel, call eapply_user earlier. Per Opportunist's request, bump up to 1.6.4 & 2.0.2 releases. Closes: https://bugs.gentoo.org/635958 Closes: https://bugs.gentoo.org/640714 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc/bird')
-rw-r--r--net-misc/bird/Manifest2
-rw-r--r--net-misc/bird/bird-1.6.4.ebuild (renamed from net-misc/bird/bird-1.6.3.ebuild)26
-rw-r--r--net-misc/bird/bird-2.0.2.ebuild36
3 files changed, 54 insertions, 10 deletions
diff --git a/net-misc/bird/Manifest b/net-misc/bird/Manifest
index 21097c326b9a..34de4ba5bf06 100644
--- a/net-misc/bird/Manifest
+++ b/net-misc/bird/Manifest
@@ -1 +1,3 @@
DIST bird-1.6.3.tar.gz 1337198 BLAKE2B e1a4a5ec4f46980f77f7c69860343da50eadea54129f20b52302aca5cdf63b19370f8cc2642b480af621772ed7b49ed7ed61a38c486f22c055abbe6be210aab9 SHA512 d0f044cbbb3e5fe0624ad8ae58f5fa352ff41a9cd73f37d803431d9d148927bce52d8f2b82e31dd65c753c55b1034aaf8e15739a511e42cd2dd122b5cd1e15df
+DIST bird-1.6.4.tar.gz 1018874 BLAKE2B f6ef0b952f6b00008fadcaa1c1a32ac31b42a9804e221edb75073e23ff942276bf1beee6d3f4c9d89f90339e99bb82a5953c17ff6963e5ff60d29a50f45e06d4 SHA512 5034d6bdca40ecddaed57bd4ab6e700828b89221bd3ce6d347aa9caa4dca65880c080ee3f276a8c31adde2de16402c8b7e7fd32dc4463d29d63b3f16b833b2eb
+DIST bird-2.0.2.tar.gz 1015224 BLAKE2B 3931c0431dc6511596e7214f6e2099548aafa69c951a44cd628443701eac061e8d95c387d74d81ad889988750c5bdb32a69ed77bfe655b161932017f1a1266a1 SHA512 aef96f246484a52269b44963df033ccc584e62d50d1ae31a97a97b9c7375e576d70d00f61a0f6da336e60cefc4c921945df0cc821d5fd1c737b19f508e65d30b
diff --git a/net-misc/bird/bird-1.6.3.ebuild b/net-misc/bird/bird-1.6.4.ebuild
index 580dd5694106..ebdf7de5c1f3 100644
--- a/net-misc/bird/bird-1.6.3.ebuild
+++ b/net-misc/bird/bird-1.6.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,34 +9,34 @@ SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug ipv6"
+KEYWORDS="~amd64 ~arm64 ~x86 ~x64-macos"
+IUSE="+client debug ipv6"
-RDEPEND="sys-libs/ncurses
- sys-libs/readline"
+RDEPEND="client? ( sys-libs/ncurses )
+ client? ( sys-libs/readline )"
DEPEND="sys-devel/flex
sys-devel/bison
sys-devel/m4"
src_prepare() {
+ eapply_user
mkdir ipv6
tar c --exclude ipv6 . | tar x -C ipv6
- eapply_user
}
src_configure() {
econf \
- --enable-client \
--disable-ipv6 \
--localstatedir="${EPREFIX}/var" \
+ $(use_enable client) \
$(use_enable debug)
if use ipv6; then
cd ipv6
econf \
- --enable-client \
--enable-ipv6 \
--localstatedir="${EPREFIX}/var" \
+ $(use_enable client) \
$(use_enable debug)
fi
}
@@ -51,11 +51,17 @@ src_compile() {
src_install() {
if use ipv6; then
- newbin ipv6/birdc birdc6
+ if use client; then
+ newbin ipv6/birdc birdc6
+ fi
+ newbin ipv6/birdcl birdcl6
newsbin ipv6/bird bird6
newinitd "${FILESDIR}/initd-v6-${PN}-1.3.8" bird6
fi
- dobin birdc
+ if use client; then
+ dobin birdc
+ fi
+ dobin birdcl
dosbin bird
newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
dodoc doc/bird.conf.example
diff --git a/net-misc/bird/bird-2.0.2.ebuild b/net-misc/bird/bird-2.0.2.ebuild
new file mode 100644
index 000000000000..b5bd01fc5519
--- /dev/null
+++ b/net-misc/bird/bird-2.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A routing daemon implementing OSPF, RIPv2 & BGP for IPv4 & IPv6"
+HOMEPAGE="http://bird.network.cz"
+SRC_URI="ftp://bird.network.cz/pub/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~x64-macos"
+IUSE="+client debug"
+
+RDEPEND="client? ( sys-libs/ncurses )
+ client? ( sys-libs/readline )"
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ sys-devel/m4"
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ $(use_enable client) \
+ $(use_enable debug)
+}
+
+src_install() {
+ if use client; then
+ dobin birdc
+ fi
+ dobin birdcl
+ dosbin bird
+ newinitd "${FILESDIR}/initd-v4-${PN}-1.3.8" bird
+ dodoc doc/bird.conf.example
+}