summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/guidedog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/guidedog')
-rw-r--r--net-misc/guidedog/Manifest1
-rw-r--r--net-misc/guidedog/guidedog-1.1-r1.ebuild45
-rw-r--r--net-misc/guidedog/metadata.xml5
3 files changed, 51 insertions, 0 deletions
diff --git a/net-misc/guidedog/Manifest b/net-misc/guidedog/Manifest
new file mode 100644
index 000000000000..db7e8cd38150
--- /dev/null
+++ b/net-misc/guidedog/Manifest
@@ -0,0 +1 @@
+DIST guidedog-1.1.tar.bz2 108059 SHA256 1ce34e72add7fcc75a1a4e743a6799e1a61d6bdbf52ad8f0d1bd8d9916a638ad SHA512 ae9820b59154311c216aec3f7b767539ea6d35ac712d9205142de29d9bb770ddc87fd8c3ae91b563556e0517ca50bfa0198191bd329f4af95beda3253510badf WHIRLPOOL 119b9b834ea0b0b703fbca229a9f1ff8a49ed7685a1991e6cf7a4d1490559b6990dd8c9cf7023e87a88bb7fb4fbabe448f1565b5c46a0b2d836e012f455a6948
diff --git a/net-misc/guidedog/guidedog-1.1-r1.ebuild b/net-misc/guidedog/guidedog-1.1-r1.ebuild
new file mode 100644
index 000000000000..8270e7d95105
--- /dev/null
+++ b/net-misc/guidedog/guidedog-1.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 kde4-base
+
+DESCRIPTION="A network/routing configuration utility for KDE 4"
+HOMEPAGE="http://www.simonzone.com/software/guidedog/"
+SRC_URI="http://www.simonzone.com/software/guidedog/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ $(add_kdebase_dep pykde4 "${PYTHON_USEDEP}")
+"
+RDEPEND="${DEPEND}
+ net-firewall/iptables
+"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_prepare() {
+ sed -e 's/python2.5/python/' -i src/sealed.py || die
+ python_fix_shebang src
+
+ kde4-base_src_prepare
+}
+
+src_install() {
+ kde4-base_src_install
+ rm -f "${ED}"usr/share/apps/guidedog/*.pyc
+}
diff --git a/net-misc/guidedog/metadata.xml b/net-misc/guidedog/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/net-misc/guidedog/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>