summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-05-03 19:29:27 -0500
committerAustin English <wizardedit@gentoo.org>2016-05-03 19:29:27 -0500
commited41380937d11362a7679bdadb6b6561f06955a6 (patch)
treed21c45b011421426cf01d9707edacab034499f18 /net-misc/orbited
parentnet-misc/netkit-timed: remove old version (diff)
downloadgentoo-ed41380937d11362a7679bdadb6b6561f06955a6.tar.gz
gentoo-ed41380937d11362a7679bdadb6b6561f06955a6.tar.bz2
gentoo-ed41380937d11362a7679bdadb6b6561f06955a6.zip
net-misc/orbited: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/orbited')
-rw-r--r--net-misc/orbited/files/orbited.init4
-rw-r--r--net-misc/orbited/orbited-0.7.10-r3.ebuild37
2 files changed, 39 insertions, 2 deletions
diff --git a/net-misc/orbited/files/orbited.init b/net-misc/orbited/files/orbited.init
index 28a9a6c03aed..ce45f0c1a3fd 100644
--- a/net-misc/orbited/files/orbited.init
+++ b/net-misc/orbited/files/orbited.init
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2009 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/net-misc/orbited/orbited-0.7.10-r3.ebuild b/net-misc/orbited/orbited-0.7.10-r3.ebuild
new file mode 100644
index 000000000000..2a70d9c31475
--- /dev/null
+++ b/net-misc/orbited/orbited-0.7.10-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Real-time communication for the browser."
+HOMEPAGE="http://orbited.org"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/demjson[${PYTHON_USEDEP}]
+ >=dev-python/morbid-0.8.4[${PYTHON_USEDEP}]
+ dev-python/stomper[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ distutils-r1_src_install
+ insinto /etc
+ doins "${FILESDIR}/orbited.cfg"
+ newinitd "${FILESDIR}/orbited.init" orbited
+}