summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2018-03-18 10:00:17 +0800
committerJason Zaman <perfinion@gentoo.org>2018-03-18 10:00:39 +0800
commit83a37b26ab6136b35baa1f1867c8766ae8e8c023 (patch)
tree2b9aa72fc806c742ec3575c5b0a6fa989d91427e /net-misc/rclone/rclone-9999.ebuild
parentmedia-gfx/graphicsmagick-1.3.27: alpha stable, bug 640690 (diff)
downloadgentoo-83a37b26ab6136b35baa1f1867c8766ae8e8c023.tar.gz
gentoo-83a37b26ab6136b35baa1f1867c8766ae8e8c023.tar.bz2
gentoo-83a37b26ab6136b35baa1f1867c8766ae8e8c023.zip
net-misc/rclone: Add bash & zfs autocompletion
Closes: https://bugs.gentoo.org/650726 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc/rclone/rclone-9999.ebuild')
-rw-r--r--net-misc/rclone/rclone-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-misc/rclone/rclone-9999.ebuild b/net-misc/rclone/rclone-9999.ebuild
index 0c936bdca50e..2c530609ee7b 100644
--- a/net-misc/rclone/rclone-9999.ebuild
+++ b/net-misc/rclone/rclone-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit golang-build
+inherit golang-build bash-completion-r1
EGO_PN="github.com/ncw/${PN}"
if [[ ${PV} == *9999* ]]; then
@@ -28,4 +28,11 @@ src_install() {
dobin ${PN}
doman src/${EGO_PN}/${PN}.1
dodoc src/${EGO_PN}/README.md
+
+ ./rclone genautocomplete bash ${PN}.bash || die
+ newbashcomp ${PN}.bash ${PN}
+
+ ./rclone genautocomplete zsh ${PN}.zsh || die
+ insinto /usr/share/zsh/site-functions
+ newins ${PN}.zsh _${PN}
}