summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2022-07-25 01:33:09 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2022-07-25 01:36:19 +0900
commit2f7b74b1f5b29766beff2d41295eba29196bd791 (patch)
treecb4ad7a008b031a05db634ab81fd0452047d8d04 /net-misc/shmux
parentnet-misc/vde: retire inactive proxied maintainer (diff)
downloadgentoo-2f7b74b1f5b29766beff2d41295eba29196bd791.tar.gz
gentoo-2f7b74b1f5b29766beff2d41295eba29196bd791.tar.bz2
gentoo-2f7b74b1f5b29766beff2d41295eba29196bd791.zip
net-misc/shmux: add 1.0.3
Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'net-misc/shmux')
-rw-r--r--net-misc/shmux/Manifest1
-rw-r--r--net-misc/shmux/files/shmux-1.0.3-tinfo.patch11
-rw-r--r--net-misc/shmux/shmux-1.0.3.ebuild43
3 files changed, 55 insertions, 0 deletions
diff --git a/net-misc/shmux/Manifest b/net-misc/shmux/Manifest
index 0d6da2ec902c..a59f0132c083 100644
--- a/net-misc/shmux/Manifest
+++ b/net-misc/shmux/Manifest
@@ -1 +1,2 @@
DIST shmux-1.0.2.tgz 110473 BLAKE2B 7dcd08c37d0d8d3ee2dfccc89ee9f2c187c97278ba7adfa8e30bd5b86981d3a4b3513dfc884926000cede0b813a922e121c49db75ca4e0ff4efde2b4b9e6480b SHA512 d114678827d4fc203f0d18b4a4e02f8b56efdf490df0aef32756a020c755b387468a88fea7266249445a862d7ed9374640432e5807fa57bca5a7d559d7e67a8a
+DIST shmux-1.0.3.tgz 116613 BLAKE2B 3d46edf3633e7d91a7fdb65e578c4541b2de35c885f1f449bdf347d3e3107ae014e6771e54b11f996a2783b303950f6ca66b46c3ef98586b932dc2fe4cb2f9ed SHA512 fb1dbb9701913fb97fb82914b9ae277703aec48cafdf74bcaa4a194ba242b62aff34e004507d6931475f320f89d62ed465360c0bc5cf2ff45abe7482b3127197
diff --git a/net-misc/shmux/files/shmux-1.0.3-tinfo.patch b/net-misc/shmux/files/shmux-1.0.3-tinfo.patch
new file mode 100644
index 000000000000..26d430a60219
--- /dev/null
+++ b/net-misc/shmux/files/shmux-1.0.3-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2022-07-25 01:23:55.820951949 +0900
++++ b/configure.ac 2022-07-25 01:24:07.870920125 +0900
+@@ -28,7 +28,7 @@ if test "x$with_pcre" != "xno"; then
+ fi
+
+ # Checks for libraries.
+-AC_SEARCH_LIBS([tgetent], [termcap curses ncurses], , AC_MSG_ERROR([terminal handling library missing]))
++AC_SEARCH_LIBS([tgetent], [termcap tinfo curses ncurses], , AC_MSG_ERROR([terminal handling library missing]))
+ AC_SEARCH_LIBS([basename], [gen])
+ if test "x$with_pcre" != "xno"; then
+ AC_SEARCH_LIBS([pcre_compile], [pcre], ,
diff --git a/net-misc/shmux/shmux-1.0.3.ebuild b/net-misc/shmux/shmux-1.0.3.ebuild
new file mode 100644
index 000000000000..07fa2c590a43
--- /dev/null
+++ b/net-misc/shmux/shmux-1.0.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="run the same command across many hosts in parallel"
+HOMEPAGE="http://web.taranis.org/shmux/"
+SRC_URI="http://web.taranis.org/${PN}/dist/${P}.tgz"
+
+LICENSE="shmux"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE="pcre"
+RESTRICT="test"
+
+RDEPEND="
+ pcre? ( dev-libs/libpcre )
+ sys-libs/ncurses:0=
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/awk"
+
+PATCHES=( "${FILESDIR}"/${P}-tinfo.patch )
+
+DOCS=( CHANGES )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with pcre)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}