summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-16 00:26:54 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-16 00:30:12 -0500
commitfd53555d823e7d2deab67e308124068d3033de1a (patch)
treee30eac6e4a32e988328420f31d11fc0d8ece5b1e /net-misc/ytfzf
parentx11-misc/screenkey: enable python 3.11 (diff)
downloadgentoo-fd53555d823e7d2deab67e308124068d3033de1a.tar.gz
gentoo-fd53555d823e7d2deab67e308124068d3033de1a.tar.bz2
gentoo-fd53555d823e7d2deab67e308124068d3033de1a.zip
net-misc/ytfzf: add 2.5.4 unkeyworded
While this fixes a few things, there's a few major regressions (e.g. with ueberzug) that seem already fixed upstream. Rather than attempt backports, expect may be another release soon so just adding unkeyworded meanwhile. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc/ytfzf')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.5.4.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index ef245162cbf8..eee178f4360e 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.5.3.tar.gz 3265442 BLAKE2B e920bf60a567741cc84739d20f282c27036eafaa823ea273439e49f9b855798a11f611ee8b4893490538d24c3039f2780451272f82ead73c45fb0f2124e05417 SHA512 fcc9e6064fe381972f30a94fd418ba9a497fed4be891f40b75e608a4c095f7b311000ae104d8e877b52622defa4ff57cb0ec1ace4d034ba08f0ff3985438d58d
+DIST ytfzf-2.5.4.tar.gz 3273455 BLAKE2B 9e4ba90cca7a17fc8c7283097db1925582b9dbb85b9b83db77f2e20a48db7566a8396114256bcb61bffb281ac0ce64f199702f495cd07f2e4e11d0c81605a973 SHA512 48ab12314a638d2682eb387c1d0bd2c8979762287194d897d801c1b845c28e3e6c2b383e1fede75e0b0649ab401855e6a9ee48a58cfc4e08b0f291da877ed150
diff --git a/net-misc/ytfzf/ytfzf-2.5.4.ebuild b/net-misc/ytfzf/ytfzf-2.5.4.ebuild
new file mode 100644
index 000000000000..17d70945b125
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.5.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+# this release seem to ahve several regressions, expecting another release soon
+#KEYWORDS="~amd64 ~x86"
+IUSE="X minimal"
+
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ app-alternatives/awk
+ !minimal? (
+ X? ( media-gfx/ueberzug )
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_prepare() {
+ default
+
+ sed -i "/^: ...YTFZF_SYSTEM_ADDON_DIR/s|/usr/local|${EPREFIX}/usr|" ytfzf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others. Set USE=minimal if want full"
+ elog "control over optional dependencies (e.g. fzf is optional if use dmenu)."
+ fi
+}