summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-12-06 23:34:24 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-12-07 04:42:30 +0100
commita651cb1a07805ad0293b60ed3068f6fcf282abd5 (patch)
tree6d08f3cc7b8886e30bf35360b8fe8ad411be4cbf /net-misc
parentdev-dotnet/dotnet-sdk: add DEPEND; sort deps (diff)
downloadgentoo-a651cb1a07805ad0293b60ed3068f6fcf282abd5.tar.gz
gentoo-a651cb1a07805ad0293b60ed3068f6fcf282abd5.tar.bz2
gentoo-a651cb1a07805ad0293b60ed3068f6fcf282abd5.zip
net-misc/croc: bump to 10.1.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/croc/Manifest2
-rw-r--r--net-misc/croc/croc-10.1.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/croc/Manifest b/net-misc/croc/Manifest
index 68c6b6ba8124..a25b41babbf9 100644
--- a/net-misc/croc/Manifest
+++ b/net-misc/croc/Manifest
@@ -4,3 +4,5 @@ DIST croc-10.0.13-deps.tar.xz 17631568 BLAKE2B b4b0a511f6f8b2d53421adbe34af5f427
DIST croc-10.0.13.tar.gz 584046 BLAKE2B 5604d7f8473da2e0648e33a3512ab0f9cedc4d995386570aa9b85428e9729ccc4153fe57b9487bffdb3d1c8e71210478887bff023215c31ac986fd4168484eb0 SHA512 b018fd1d26b84456d792c0d7e7c1a4cbcd796d7bac5acc802afea1d6c5082310a11d6d91efef721506e35bd3f1a35bea85382f2a041c81d875a404df02c3f5d7
DIST croc-10.1.0-deps.tar.xz 18220572 BLAKE2B 3c1513bf9dc52e72e37f34ad843daf30b4d8accb5de6a1073535870dd1e5d7993f9234312208dfae30726e1ce3f23c0c700ebedc6c6f2a7f3c610ce611940224 SHA512 8dd23262d529c66927b0a60b41b7234675577593cddc8c553a367f5203f3d4736b66cb258881a89603233cccc709923268e2ccdd78aa47c38d3dabdf072d0de1
DIST croc-10.1.0.tar.gz 583893 BLAKE2B d728c8f6dc08179910343e17304b50138c93a7af8ca11c8b1d8fa8a43b4e542f811eec1898948c6c62c99d2f50a96363db0dc15f48fc2b6e98224a9fdf3a040c SHA512 dba6a792c25766056aa851c10ec5a441a66404e41af50f2585ae7b7e35ce0e85972b4fbb93b374589ceb475c3fd35ad413251eb010fadc40cddede07a2831940
+DIST croc-10.1.1-deps.tar.xz 18133544 BLAKE2B 3f1640936ac0ada372e56060598caa3bc43fe328223596761d899655a188d944bad717b0e80b859a2e89e4f53c88c1dca1a03ec8bd1a3f45407af983271baf97 SHA512 3fe980990438ff2fc1835f1c413be8799978c1312da6262fbe5e135408b21fd907f6aef4e385b3bfe9694addfdefc09c2aef634181e5b717baccc40d0355ab61
+DIST croc-10.1.1.tar.gz 584146 BLAKE2B 8463d916e2fb8ec73d27678f191dc50dbcce25f971495e0f51ded2d964337d311d02988a92c85948b21f2533921250569b4128c185c165d2678e1a4cb009d974 SHA512 1a7038bacc1b4d8235f5193a794e04588f8e17d4d3fa1db463641ca34637c4e81de6fcce1a9805d660f8f2208e563cf2efa37ddd407f43e1fe6032c0a5a06d24
diff --git a/net-misc/croc/croc-10.1.1.ebuild b/net-misc/croc/croc-10.1.1.ebuild
new file mode 100644
index 000000000000..edfe827fbac5
--- /dev/null
+++ b/net-misc/croc/croc-10.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module systemd
+
+DESCRIPTION="Easily and securely send things from one computer to another"
+HOMEPAGE="https://github.com/schollz/croc"
+SRC_URI="https://github.com/schollz/croc/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.xz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ acct-group/croc
+ acct-user/croc
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+ default
+ # Replace User=nobody with User=croc
+ sed -i -e "s|\(^User=\).*|\1croc|g" croc.service || die
+ # Rename bash completion function
+ sed -i -e "s|_cli_bash_autocomplete|_croc|g" \
+ src/install/bash_autocomplete || die
+}
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin croc
+ systemd_dounit croc.service
+ newbashcomp src/install/bash_autocomplete croc
+ einstalldocs
+}
+
+src_test() {
+ ego test -skip "Test(Comm|Send|PublicIP|LocalIP)" -work ./...
+}