summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2019-09-19 23:38:43 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-28 09:46:14 +0300
commitf02a3bf0a1f4c5d58fc553d9a85fe44229e1be76 (patch)
tree9fdc199ac1c0c10941f9578a1487347f45d8693e /net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.22.ebuild
parentacct-user/ipfs: Add user for net-p2p/go-ipfs-bin (UID 484) (diff)
downloadgentoo-f02a3bf0a1f4c5d58fc553d9a85fe44229e1be76.tar.gz
gentoo-f02a3bf0a1f4c5d58fc553d9a85fe44229e1be76.tar.bz2
gentoo-f02a3bf0a1f4c5d58fc553d9a85fe44229e1be76.zip
net-p2p/go-ipfs-bin: Bump to 0.4.22
Bump to 0.4.22 and fix systemd unit files on that way. This revision installs both variants, a user instance unit and a unit mirroring what the openrc version does (using the "ipfs" user). Closes: https://bugs.gentoo.org/643634 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.22.ebuild')
-rw-r--r--net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.22.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.22.ebuild b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.22.ebuild
new file mode 100644
index 000000000000..c4af0136eb9e
--- /dev/null
+++ b/net-p2p/go-ipfs-bin/go-ipfs-bin-0.4.22.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 systemd
+
+DESCRIPTION="Main implementation of IPFS"
+HOMEPAGE="https://ipfs.io/"
+SRC_URI="amd64? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-amd64.tar.gz )
+ x86? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-386.tar.gz )
+ arm? ( https://dist.ipfs.io/go-ipfs/v${PV}/go-ipfs_v${PV}_linux-arm.tar.gz )
+
+ https://raw.githubusercontent.com/ipfs/go-ipfs/v${PV}/misc/completion/ipfs-completion.bash -> ${P}.bash"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~x86"
+
+RDEPEND="
+ acct-group/ipfs
+ acct-user/ipfs
+ sys-fs/fuse:0
+"
+
+S="${WORKDIR}/go-ipfs"
+
+QA_PREBUILT="/usr/bin/ipfs"
+
+src_install() {
+ dobin ipfs
+
+ systemd_dounit "${FILESDIR}/ipfs.service"
+ systemd_newunit "${FILESDIR}/ipfs-at.service" "ipfs@.service"
+
+ newinitd "${FILESDIR}/ipfs.init" ipfs
+ newconfd "${FILESDIR}/ipfs.confd" ipfs
+
+ newbashcomp "${DISTDIR}/${P}.bash" "ipfs"
+ keepdir /var/log/ipfs
+}
+
+pkg_preinst() {
+ fowners -R ipfs:ipfs /var/log/ipfs
+}
+
+pkg_postinst() {
+ elog 'To be able to use the ipfs service you will need to create the ipfs repository'
+ elog '(eg: su -s /bin/sh -c "ipfs init -e" ipfs)'
+ elog 'or change IPFS_PATH of /etc/conf.d/ipfs with another with proper permissions.'
+}