summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-04-17 09:47:11 -0400
committerCraig Andrews <candrews@gentoo.org>2024-04-17 09:47:27 -0400
commit464c1ffd6d6b3177203a143d9168bfc7bb6bbe25 (patch)
treea17072890eb793cb7db3dae1b043c6a3c3a02ac4 /net-p2p
parentdev-python/pywlroots: Bump to 0.16.7 (diff)
downloadgentoo-464c1ffd6d6b3177203a143d9168bfc7bb6bbe25.tar.gz
gentoo-464c1ffd6d6b3177203a143d9168bfc7bb6bbe25.tar.bz2
gentoo-464c1ffd6d6b3177203a143d9168bfc7bb6bbe25.zip
net-p2p/cpuminer-opt: add 24.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-24.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index ebfc42a81759..366fce37aa43 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-23.9.tar.gz 1789859 BLAKE2B a1a4594100a28c5eba9a2db3284944e61bb96b7fa118c44a4a97d66ada8df33f0e6feb74fb0cc507598b23980cd32f2839c5dc54abd4520fb875ab465da9d657 SHA512 76d81dcac0c631c46b1fa5b8c5918b21b900cafa00f1a56f72af87924b90b2c947b09f5aaed30d478e6e0e77b3ac6111e3e537e52460514185e3d2787db5ca11
+DIST cpuminer-opt-24.1.tar.gz 1790880 BLAKE2B 8a14df69c612bd9d00ec59a4da36b468b285f04731d8b943edea3af05bf0baf676a540e0daf3b411df3803b02314a6c6588c276cd38e2107918402f364d8b644 SHA512 f76dc5695f0baa745a6e6379ff4b105b18a183088a26eede31dbada6da5459eaceaecf22213dff21c95bf99ca6a5e179af839c1e742e1212f209ff6e8ed5fc6a
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-24.1.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-24.1.ebuild
new file mode 100644
index 000000000000..2683d4bdc544
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-24.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ newins config-template.json cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}