summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-05-30 12:00:51 -0400
committerCraig Andrews <candrews@gentoo.org>2024-05-30 12:02:48 -0400
commitf7ad0d6672f45cccd8ad60613fe2319a732614c5 (patch)
tree9dbf89139a14c6f15f8e9f4c4fda6054caa18a5d /net-p2p
parentnet-p2p/transmission: add 4.0.6 (diff)
downloadgentoo-f7ad0d6672f45cccd8ad60613fe2319a732614c5.tar.gz
gentoo-f7ad0d6672f45cccd8ad60613fe2319a732614c5.tar.bz2
gentoo-f7ad0d6672f45cccd8ad60613fe2319a732614c5.zip
net-p2p/cpuminer-opt: add 24.3
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-24.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 3ca1de1b9c11..884b07f18b67 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-24.2.tar.gz 1790962 BLAKE2B 16ff1664211ee8b48e5690a371a358f66eb9b38a550006b136c85cd258f35cb046d49d9f11167937a5f8d3926ecb374a9acecf56ba1c91bec48d6688aea7879a SHA512 393d5b2759078e67f0220f0362468540b69e6e2db2bb9adda1c92c3e8bca5fd8b944ad83e6e948f13216c3c4bd49aaf9d4d4b01e893aa35c56fa82af662c571f
+DIST cpuminer-opt-24.3.tar.gz 1791024 BLAKE2B 7b563f48f2170dd73cd790243bf5b2043cee85f8f25655f805f2c0aeba96e580047cdb10a6a8bda4a2942a8417a1422dd884aebd9593f0b1b0cd0ed9cb4ceb53 SHA512 4ba7043b5226d2cef8fd25044942b01245c8ae7c9088e7b1e07f115b4f6592e2746cd2261a123d94344f81c12f4ceb897579ebbfa048569779f9cd5ee65d9c50
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-24.3.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-24.3.ebuild
new file mode 100644
index 000000000000..2683d4bdc544
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-24.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ newins config-template.json cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}