summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-11-18 20:37:28 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-11-18 20:37:49 +0100
commitf9e4fce109fc8806935648a17ddcf7109b52c7ef (patch)
tree61024492abe171e384aa8f214ea8ac82c28bcb26 /net-vpn/wireguard-modules
parentmedia-libs/hamlib: Add python3.8 support (diff)
downloadgentoo-f9e4fce109fc8806935648a17ddcf7109b52c7ef.tar.gz
gentoo-f9e4fce109fc8806935648a17ddcf7109b52c7ef.tar.bz2
gentoo-f9e4fce109fc8806935648a17ddcf7109b52c7ef.zip
net-vpn/wireguard-modules: stable x86/amd64
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'net-vpn/wireguard-modules')
-rw-r--r--net-vpn/wireguard-modules/Manifest1
-rw-r--r--net-vpn/wireguard-modules/wireguard-modules-1.0.20200908.ebuild99
-rw-r--r--net-vpn/wireguard-modules/wireguard-modules-1.0.20201112.ebuild2
3 files changed, 1 insertions, 101 deletions
diff --git a/net-vpn/wireguard-modules/Manifest b/net-vpn/wireguard-modules/Manifest
index 8b1c9a0c59c5..e908603ee4b0 100644
--- a/net-vpn/wireguard-modules/Manifest
+++ b/net-vpn/wireguard-modules/Manifest
@@ -1,2 +1 @@
-DIST wireguard-linux-compat-1.0.20200908.tar.xz 262708 BLAKE2B e1621237c6a76a6b8111eb26d2547c7335d87f8e11110db29fd6d7b8c56993d0998383a2beab682c75caa0de183f17e345b0f96794a7c9e5b2cd04281d558ce0 SHA512 e13f243a7a72a4d4bd326af40439b7760b6ea8b452e67ddff1c844dc62bc53e2dc2c1738f98c7a45b6b24566d0ed9dc0dc3e9006fcb668f0314aac2ab9eaeb87
DIST wireguard-linux-compat-1.0.20201112.tar.xz 262220 BLAKE2B 2bbcce294c7d0578e820b285074bdbff2c96908ccc10294e05aa846a6f0b614930ca71536cb954233480c9e294692df1f4954b8f11db86deecdc93373b6e1d4f SHA512 c3ad6611d1d8abf163e6626ceeb1329b8b4a745159021473fee134858e22f6a5d3418b39f165f2f2f0bde1891d560f773cdb4d1f4fb60d61b35aff01d59aee54
diff --git a/net-vpn/wireguard-modules/wireguard-modules-1.0.20200908.ebuild b/net-vpn/wireguard-modules/wireguard-modules-1.0.20200908.ebuild
deleted file mode 100644
index a3aea3fe6a50..000000000000
--- a/net-vpn/wireguard-modules/wireguard-modules-1.0.20200908.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MODULES_OPTIONAL_USE="module"
-inherit linux-mod bash-completion-r1
-
-DESCRIPTION="Simple yet fast and modern VPN that utilizes state-of-the-art cryptography."
-HOMEPAGE="https://www.wireguard.com/"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.zx2c4.com/wireguard-linux-compat"
-else
- SRC_URI="https://git.zx2c4.com/wireguard-linux-compat/snapshot/wireguard-linux-compat-${PV}.tar.xz"
- S="${WORKDIR}/wireguard-linux-compat-${PV}"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug +module module-src"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-MODULE_NAMES="wireguard(kernel/drivers/net:src)"
-BUILD_TARGETS="module"
-CONFIG_CHECK="NET INET NET_UDP_TUNNEL CRYPTO_ALGAPI"
-
-pkg_setup() {
- if use module; then
- linux-mod_pkg_setup
- if [[ -f $KERNEL_DIR/include/uapi/linux/wireguard.h ]]; then
- eerror
- eerror "WireGuard has been merged upstream into this kernel. Therefore,"
- eerror "you no longer need this compatibility ebuild. Instead, simply"
- eerror "enable CONFIG_WIREGUARD=y in your kernel configuration."
- eerror
- die "Use CONFIG_WIREGUARD=y for this kernel, and do not use this package."
- elif kernel_is -lt 3 10 0 || kernel_is -ge 5 6 0; then
- die "This version of ${PN} requires Linux >= 3.10 and < 5.6."
- fi
- fi
-}
-
-src_compile() {
- BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
- use debug && BUILD_PARAMS="CONFIG_WIREGUARD_DEBUG=y ${BUILD_PARAMS}"
- use module && linux-mod_src_compile
-}
-
-src_install() {
- use module && linux-mod_src_install
- use module-src && emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" -C src dkms-install
-}
-
-pkg_postinst() {
- if use module-src && ! use module; then
- einfo
- einfo "You have enabled the module-src USE flag without the module USE"
- einfo "flag. This means that sources are installed to"
- einfo "${ROOT}/usr/src/wireguard instead of having the"
- einfo "kernel module compiled. You will need to compile the module"
- einfo "yourself. Most likely, you don't want this USE flag, and should"
- einfo "rather use USE=module"
- einfo
- fi
-
- if use module; then
- linux-mod_pkg_postinst
- local old new
- if [[ $(uname -r) != "${KV_FULL}" ]]; then
- ewarn
- ewarn "You have just built WireGuard for kernel ${KV_FULL}, yet the currently running"
- ewarn "kernel is $(uname -r). If you intend to use this WireGuard module on the currently"
- ewarn "running machine, you will first need to reboot it into the kernel ${KV_FULL}, for"
- ewarn "which this module was built."
- ewarn
- elif [[ -f /sys/module/wireguard/version ]] && \
- old="$(< /sys/module/wireguard/version)" && \
- new="$(modinfo -F version "${ROOT}/lib/modules/${KV_FULL}/net/wireguard.ko" 2>/dev/null)" && \
- [[ $old != "$new" ]]; then
- ewarn
- ewarn "You appear to have just upgraded WireGuard from version v$old to v$new."
- ewarn "However, the old version is still running on your system. In order to use the"
- ewarn "new version, you will need to remove the old module and load the new one. As"
- ewarn "root, you can accomplish this with the following commands:"
- ewarn
- ewarn " # rmmod wireguard"
- ewarn " # modprobe wireguard"
- ewarn
- ewarn "Do note that doing this will remove current WireGuard interfaces, so you may want"
- ewarn "to gracefully remove them yourself prior."
- ewarn
- fi
- fi
-}
diff --git a/net-vpn/wireguard-modules/wireguard-modules-1.0.20201112.ebuild b/net-vpn/wireguard-modules/wireguard-modules-1.0.20201112.ebuild
index a346e8fae151..a3aea3fe6a50 100644
--- a/net-vpn/wireguard-modules/wireguard-modules-1.0.20201112.ebuild
+++ b/net-vpn/wireguard-modules/wireguard-modules-1.0.20201112.ebuild
@@ -15,7 +15,7 @@ if [[ ${PV} == 9999 ]]; then
else
SRC_URI="https://git.zx2c4.com/wireguard-linux-compat/snapshot/wireguard-linux-compat-${PV}.tar.xz"
S="${WORKDIR}/wireguard-linux-compat-${PV}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
fi
LICENSE="GPL-2"