summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-27 01:55:29 +0100
committerSam James <sam@gentoo.org>2024-04-27 01:55:29 +0100
commitde42887364fb0681a6045f33b48dfefe58c46298 (patch)
treee171780be674a18760d3b38d9796459e69ddb43e /net-vpn
parentnet-misc/anydesk: drop 6.2.1-r1, 6.3.1 (diff)
downloadgentoo-de42887364fb0681a6045f33b48dfefe58c46298.tar.gz
gentoo-de42887364fb0681a6045f33b48dfefe58c46298.tar.bz2
gentoo-de42887364fb0681a6045f33b48dfefe58c46298.zip
net-vpn/pptpd: fix Modern C issue
Interestingly, this only seems to manifest with >=glibc-2.38, because the include had a '#ifndef HAVE_STRLCPY' guard. Closes: https://bugs.gentoo.org/920775 Closes: https://bugs.gentoo.org/927333 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/pptpd/files/pptpd-1.4.0-c99.patch16
-rw-r--r--net-vpn/pptpd/pptpd-1.4.0-r4.ebuild (renamed from net-vpn/pptpd/pptpd-1.4.0-r3.ebuild)3
2 files changed, 18 insertions, 1 deletions
diff --git a/net-vpn/pptpd/files/pptpd-1.4.0-c99.patch b/net-vpn/pptpd/files/pptpd-1.4.0-c99.patch
new file mode 100644
index 000000000000..902a275d5f35
--- /dev/null
+++ b/net-vpn/pptpd/files/pptpd-1.4.0-c99.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/920775
+https://bugs.gentoo.org/927333
+
+--- a/compat.c
++++ b/compat.c
+@@ -10,9 +10,9 @@
+
+ #include "compat.h"
+ #include "our_syslog.h"
++#include <string.h>
+
+ #ifndef HAVE_STRLCPY
+-#include <string.h>
+ #include <stdio.h>
+
+ void strlcpy(char *dst, const char *src, size_t size)
diff --git a/net-vpn/pptpd/pptpd-1.4.0-r3.ebuild b/net-vpn/pptpd/pptpd-1.4.0-r4.ebuild
index 425dcbcb8d78..c5805c7696e2 100644
--- a/net-vpn/pptpd/pptpd-1.4.0-r3.ebuild
+++ b/net-vpn/pptpd/pptpd-1.4.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,6 +40,7 @@ src_prepare() {
"${FILESDIR}/${P}-pidfile.patch"
"${FILESDIR}/${P}-libdir.patch"
"${FILESDIR}/${P}-musl.patch"
+ "${FILESDIR}/${P}-c99.patch"
)
if has_version -d ">=net-dialup/ppp-2.5.0"; then