summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-12-21 10:22:41 +0100
committerPacho Ramos <pacho@gentoo.org>2023-12-21 10:23:03 +0100
commit908539cda2d09793344370cd12b06e3adc5419b2 (patch)
treedb260163be13a69dcf5e75d335f7ed0408277ecb /net-wireless
parentnet-misc/nextcloud-client: add new qtsql dependency (diff)
downloadgentoo-908539cda2d09793344370cd12b06e3adc5419b2.tar.gz
gentoo-908539cda2d09793344370cd12b06e3adc5419b2.tar.bz2
gentoo-908539cda2d09793344370cd12b06e3adc5419b2.zip
net-wireless/bluez: Fix auto-connect with older kernels
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bluez/bluez-5.71-r1.ebuild288
-rw-r--r--net-wireless/bluez/files/bluez-5.71-link-old-kernels.patch163
2 files changed, 451 insertions, 0 deletions
diff --git a/net-wireless/bluez/bluez-5.71-r1.ebuild b/net-wireless/bluez/bluez-5.71-r1.ebuild
new file mode 100644
index 000000000000..c7392ed1615f
--- /dev/null
+++ b/net-wireless/bluez/bluez-5.71-r1.ebuild
@@ -0,0 +1,288 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit autotools linux-info python-single-r1 systemd udev multilib-minimal #readme.gentoo-r1
+
+DESCRIPTION="Bluetooth Tools and System Daemons for Linux"
+HOMEPAGE="http://www.bluez.org https://github.com/bluez/bluez"
+SRC_URI="https://www.kernel.org/pub/linux/bluetooth/${P}.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="btpclient cups doc debug deprecated extra-tools experimental +mesh midi +obex +readline selinux systemd test test-programs +udev"
+
+# Since this release all remaining extra-tools need readline support, but this could
+# change in the future, hence, this REQUIRED_USE constraint could be dropped
+# again in the future.
+# btpclient needs mesh, bug #790587
+REQUIRED_USE="
+ btpclient? ( mesh )
+ extra-tools? ( deprecated readline )
+ test? ( ${PYTHON_REQUIRED_USE} )
+ test-programs? ( ${PYTHON_REQUIRED_USE} )
+"
+
+TEST_DEPS="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/dbus-python-1[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ dev-python/docutils
+ virtual/pkgconfig
+ test? ( ${TEST_DEPS} )
+"
+DEPEND="
+ >=dev-libs/glib-2.28:2[${MULTILIB_USEDEP}]
+ btpclient? ( >=dev-libs/ell-0.39 )
+ cups? ( net-print/cups:= )
+ mesh? (
+ >=dev-libs/ell-0.39
+ >=dev-libs/json-c-0.13:=
+ sys-libs/readline:0=
+ )
+ midi? ( media-libs/alsa-lib )
+ obex? ( dev-libs/libical:= )
+ readline? ( sys-libs/readline:0= )
+ systemd? ( sys-apps/systemd )
+ >=sys-apps/dbus-1.6:=
+ udev? ( >=virtual/udev-172 )
+"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-bluetooth )
+ test-programs? ( ${TEST_DEPS} )
+"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ # Try both udevadm paths to cover udev/systemd vs. eudev locations (#539844)
+ # http://www.spinics.net/lists/linux-bluetooth/msg58739.html
+ # https://bugs.gentoo.org/539844
+ # https://github.com/bluez/bluez/issues/268
+ "${FILESDIR}"/${PN}-udevadm-path-r1.patch
+
+ # Fedora patches
+ # https://lore.kernel.org/linux-bluetooth/20220901110719.176944-1-hadess@hadess.net/T/#m9c08d004cd5422783ee1d93154f42303bba9169f
+ "${FILESDIR}"/${PN}-5.66-power-state-adapter-property.patch
+
+ # https://github.com/bluez/bluez/issues/686
+ "${FILESDIR}"/${P}-link-old-kernels.patch
+)
+
+pkg_setup() {
+ # From http://www.linuxfromscratch.org/blfs/view/svn/general/bluez.html
+ # to prevent bugs like:
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+ CONFIG_CHECK="~NET ~BT ~BT_RFCOMM ~BT_RFCOMM_TTY ~BT_BNEP ~BT_BNEP_MC_FILTER
+ ~BT_BNEP_PROTO_FILTER ~BT_HIDP ~CRYPTO_USER_API_HASH ~CRYPTO_USER_API_SKCIPHER
+ ~UHID ~RFKILL"
+ # https://bugzilla.kernel.org/show_bug.cgi?id=196621
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206815
+ if use mesh || use test; then
+ CONFIG_CHECK="${CONFIG_CHECK} ~CRYPTO_USER
+ ~CRYPTO_USER_API ~CRYPTO_USER_API_AEAD ~CRYPTO_AES ~CRYPTO_CCM ~CRYPTO_AEAD ~CRYPTO_CMAC
+ ~CRYPTO_MD5 ~CRYPTO_SHA1 ~KEY_DH_OPERATIONS"
+ fi
+ linux-info_pkg_setup
+
+ if use test || use test-programs; then
+ python-single-r1_pkg_setup
+ fi
+
+ if ! use udev; then
+ ewarn
+ ewarn "You are installing ${PN} with USE=-udev. This means various bluetooth"
+ ewarn "devices and adapters from Apple, Dell, Logitech etc. will not work,"
+ ewarn "and hid2hci will not be available."
+ ewarn
+ fi
+}
+
+src_prepare() {
+ default
+
+ # http://www.spinics.net/lists/linux-bluetooth/msg38490.html
+ if ! use systemd; then
+ eapply "${FILESDIR}"/0001-Allow-using-obexd-without-systemd-in-the-user-session-r2.patch
+ fi
+
+ eautoreconf
+
+ if use cups; then
+ # Only not .am to not need to run eautoreconf only because of this
+ sed -i \
+ -e "s:cupsdir = \$(libdir)/cups:cupsdir = $(cups-config --serverbin):" \
+ Makefile.{in,tools} || die
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local myconf=(
+ # readline is automagic when client is enabled
+ # --enable-client always needs readline, bug #504038
+ # --enable-mesh is handled in the same way
+ ac_cv_header_readline_readline_h=$(multilib_native_usex readline)
+ ac_cv_header_readline_readline_h=$(multilib_native_usex mesh)
+ )
+
+ if ! multilib_is_native_abi; then
+ myconf+=(
+ # deps not used for the library
+ {DBUS,GLIB}_{CFLAGS,LIBS}=' '
+ )
+ fi
+
+ econf \
+ --localstatedir=/var \
+ --disable-android \
+ --enable-datafiles \
+ --enable-optimization \
+ $(use_enable debug) \
+ --enable-pie \
+ --enable-threads \
+ --enable-library \
+ --enable-tools \
+ --enable-manpages \
+ --enable-monitor \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ $(multilib_native_use_enable btpclient) \
+ $(multilib_native_use_enable btpclient external-ell) \
+ $(multilib_native_use_enable cups) \
+ $(multilib_native_use_enable deprecated) \
+ $(multilib_native_use_enable experimental) \
+ $(multilib_native_use_enable mesh) \
+ $(multilib_native_use_enable mesh external-ell) \
+ $(multilib_native_use_enable midi) \
+ $(multilib_native_use_enable obex) \
+ $(multilib_native_use_enable readline client) \
+ $(multilib_native_use_enable systemd) \
+ $(multilib_native_use_enable test-programs test) \
+ $(multilib_native_use_enable udev) \
+ $(multilib_native_use_enable udev hid2hci) \
+ $(multilib_native_use_enable udev sixaxis)
+}
+
+multilib_src_compile() {
+ if multilib_is_native_abi; then
+ default
+ else
+ emake -f Makefile -f - libs \
+ <<<'libs: $(lib_LTLIBRARIES)'
+ fi
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && default
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi; then
+ emake DESTDIR="${D}" install
+
+ # Only install extra-tools when relevant USE flag is enabled
+ if use extra-tools; then
+ ewarn "Upstream doesn't support using this tools and their bugs are"
+ ewarn "likely to be ignored forever, also they can break without"
+ ewarn "previous announcement."
+ ewarn "Upstream also states all this tools are not really needed,"
+ ewarn "then, if you still need to rely on them, you must ask them"
+ ewarn "to either install that tool by default or add the needed"
+ ewarn "functionality to the existing 'official' tools."
+ ewarn "Please report this issues to:"
+ ewarn "http://www.bluez.org/development/lists/"
+
+ # Upstream doesn't install this, bug #524640
+ # http://permalink.gmane.org/gmane.linux.bluez.kernel/53115
+ # http://comments.gmane.org/gmane.linux.bluez.kernel/54564
+ dobin tools/btmgmt
+ # gatttool is only built with readline, bug #530776
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1141909
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=720486
+ # https://bugs.archlinux.org/task/37686
+ dobin attrib/gatttool
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1699680
+ dobin tools/avinfo
+ fi
+
+ # Not installed by default after being built, bug #666756
+ use btpclient && dobin tools/btpclient
+
+ # Unittests are not that useful once installed, so make them optional
+ if use test-programs; then
+ # Drop python2 only test tools
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206819
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/simple-player || die
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206821
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/test-hfp || die
+ # https://bugzilla.kernel.org/show_bug.cgi?id=206823
+ rm "${ED}"/usr/$(get_libdir)/bluez/test/test-sap-server || die
+
+ python_fix_shebang "${ED}"/usr/$(get_libdir)/bluez/test
+
+ for i in $(find "${ED}"/usr/$(get_libdir)/bluez/test -maxdepth 1 -type f ! -name "*.*"); do
+ dosym "${i}" /usr/bin/bluez-"${i##*/}"
+ done
+ fi
+ else
+ emake DESTDIR="${D}" \
+ install-pkgincludeHEADERS \
+ install-libLTLIBRARIES \
+ install-pkgconfigDATA
+ fi
+}
+
+multilib_src_install_all() {
+ # We need to ensure obexd can be spawned automatically by systemd
+ # when user-session is enabled:
+ # http://marc.info/?l=linux-bluetooth&m=148096094716386&w=2
+ # https://bugs.gentoo.org/show_bug.cgi?id=577842
+ # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804908
+ # https://bugs.archlinux.org/task/45816
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1318441
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1389347
+ if use systemd; then
+ dosym obex.service /usr/lib/systemd/user/dbus-org.bluez.obex.service
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ keepdir /var/lib/bluetooth
+
+ # Upstream don't want people to play with them
+ # But we keep installing them due to 'historical' reasons
+ insinto /etc/bluetooth
+ local d
+ for d in input network; do
+ doins profiles/${d}/${d}.conf
+ done
+ # Setup auto enable as Fedora does for allowing to use
+ # keyboards/mouse as soon as possible
+ sed -i 's/#\[Policy\]$/\[Policy\]/; s/#AutoEnable=false/AutoEnable=true/' src/main.conf || die
+ doins src/main.conf
+
+ newinitd "${FILESDIR}"/bluetooth-init.d-r5 bluetooth
+ newconfd "${FILESDIR}"/bluetooth-conf.d bluetooth
+
+ einstalldocs
+ use doc && dodoc doc/*.txt
+}
+
+pkg_postinst() {
+ use udev && udev_reload
+ systemd_reenable bluetooth.service
+
+ has_version net-dialup/ppp || elog "To use dial up networking you must install net-dialup/ppp"
+}
+
+pkg_postrm() {
+ use udev && udev_reload
+}
diff --git a/net-wireless/bluez/files/bluez-5.71-link-old-kernels.patch b/net-wireless/bluez/files/bluez-5.71-link-old-kernels.patch
new file mode 100644
index 000000000000..33cee137f277
--- /dev/null
+++ b/net-wireless/bluez/files/bluez-5.71-link-old-kernels.patch
@@ -0,0 +1,163 @@
+From 7ad5669402c9acff8e4cc808edc12a41df36654e Mon Sep 17 00:00:00 2001
+From: Luiz Augusto von Dentz <luiz.von.dentz@intel.com>
+Date: Wed, 20 Dec 2023 12:20:03 -0500
+Subject: [PATCH] adapter: Fix link key address type for old kernels
+
+On old kernels only BDADDR_BREDR is supported so this attempts to detect
+that and retry.
+
+Fixes: https://github.com/bluez/bluez/issues/686
+---
+ src/adapter.c | 59 ++++++++++++++++++++++++++++++++++++++-------------
+ 1 file changed, 44 insertions(+), 15 deletions(-)
+
+diff --git a/src/adapter.c b/src/adapter.c
+index ee70b00d2..022390f0d 100644
+--- a/src/adapter.c
++++ b/src/adapter.c
+@@ -311,6 +311,7 @@ struct btd_adapter {
+ bool pincode_requested; /* PIN requested during last bonding */
+ GSList *connections; /* Connected devices */
+ GSList *devices; /* Devices structure pointers */
++ GSList *load_keys; /* Devices keys to be loaded */
+ GSList *connect_list; /* Devices to connect when found */
+ struct btd_device *connect_le; /* LE device waiting to be connected */
+ sdp_list_t *services; /* Services associated to adapter */
+@@ -4284,6 +4285,9 @@ static int set_privacy(struct btd_adapter *adapter, uint8_t privacy)
+ return -1;
+ }
+
++static void load_link_keys(struct btd_adapter *adapter, bool debug_keys,
++ bool retry);
++
+ static void load_link_keys_complete(uint8_t status, uint16_t length,
+ const void *param, void *user_data)
+ {
+@@ -4293,18 +4297,31 @@ static void load_link_keys_complete(uint8_t status, uint16_t length,
+ btd_error(adapter->dev_id,
+ "Failed to load link keys for hci%u: %s (0x%02x)",
+ adapter->dev_id, mgmt_errstr(status), status);
++
++ if (status == MGMT_STATUS_INVALID_PARAMS) {
++ load_link_keys(adapter, btd_opts.debug_keys, true);
++ /* Release keys after retry since we shall only retry
++ * once.
++ */
++ goto done;
++ }
++
+ return;
+ }
+
+ DBG("link keys loaded for hci%u", adapter->dev_id);
++
++done:
++ g_slist_free_full(adapter->load_keys, g_free);
++ adapter->load_keys = NULL;
+ }
+
+-static void load_link_keys(struct btd_adapter *adapter, GSList *keys,
+- bool debug_keys)
++static void load_link_keys(struct btd_adapter *adapter, bool debug_keys,
++ bool retry)
+ {
+ struct mgmt_cp_load_link_keys *cp;
+ struct mgmt_link_key_info *key;
+- size_t key_count, cp_size;
++ size_t count, cp_size;
+ unsigned int id;
+ GSList *l;
+
+@@ -4318,12 +4335,14 @@ static void load_link_keys(struct btd_adapter *adapter, GSList *keys,
+ if (!(adapter->supported_settings & MGMT_SETTING_BREDR))
+ return;
+
+- key_count = g_slist_length(keys);
++ count = g_slist_length(adapter->load_keys);
++ if (!count)
++ return;
+
+- DBG("hci%u keys %zu debug_keys %d", adapter->dev_id, key_count,
+- debug_keys);
++ DBG("hci%u keys %zu debug_keys %d retry %s", adapter->dev_id, count,
++ debug_keys, retry ? "true" : "false");
+
+- cp_size = sizeof(*cp) + (key_count * sizeof(*key));
++ cp_size = sizeof(*cp) + (count * sizeof(*key));
+
+ cp = g_try_malloc0(cp_size);
+ if (cp == NULL) {
+@@ -4341,13 +4360,18 @@ static void load_link_keys(struct btd_adapter *adapter, GSList *keys,
+ * behavior for debug keys.
+ */
+ cp->debug_keys = debug_keys;
+- cp->key_count = htobs(key_count);
++ cp->key_count = htobs(count);
+
+- for (l = keys, key = cp->keys; l != NULL; l = g_slist_next(l), key++) {
++ for (l = adapter->load_keys, key = cp->keys; l != NULL;
++ l = g_slist_next(l), key++) {
+ struct link_key_info *info = l->data;
+
+ bacpy(&key->addr.bdaddr, &info->bdaddr);
+- key->addr.type = info->bdaddr_type;
++ /* Old kernels might only support loading with type set to
++ * BDADDR_BREDR so on retry set that instead of using the stored
++ * info.
++ */
++ key->addr.type = retry ? BDADDR_BREDR : info->bdaddr_type;
+ key->type = info->type;
+ memcpy(key->val, info->key, 16);
+ key->pin_len = info->pin_len;
+@@ -4359,9 +4383,12 @@ static void load_link_keys(struct btd_adapter *adapter, GSList *keys,
+
+ g_free(cp);
+
+- if (id == 0)
++ if (id == 0) {
+ btd_error(adapter->dev_id, "Failed to load link keys for hci%u",
+ adapter->dev_id);
++ g_slist_free_full(adapter->load_keys, g_free);
++ adapter->load_keys = NULL;
++ }
+ }
+
+ static void load_ltks_complete(uint8_t status, uint16_t length,
+@@ -4873,7 +4900,6 @@ static void load_defaults(struct btd_adapter *adapter)
+ static void load_devices(struct btd_adapter *adapter)
+ {
+ char dirname[PATH_MAX];
+- GSList *keys = NULL;
+ GSList *ltks = NULL;
+ GSList *irks = NULL;
+ GSList *params = NULL;
+@@ -4964,7 +4990,8 @@ static void load_devices(struct btd_adapter *adapter)
+ }
+
+ if (key_info)
+- keys = g_slist_append(keys, key_info);
++ adapter->load_keys = g_slist_append(adapter->load_keys,
++ key_info);
+
+ if (ltk_info)
+ ltks = g_slist_append(ltks, ltk_info);
+@@ -5013,8 +5040,7 @@ static void load_devices(struct btd_adapter *adapter)
+
+ closedir(dir);
+
+- load_link_keys(adapter, keys, btd_opts.debug_keys);
+- g_slist_free_full(keys, g_free);
++ load_link_keys(adapter, btd_opts.debug_keys, false);
+
+ load_ltks(adapter, ltks);
+ g_slist_free_full(ltks, g_free);
+@@ -6930,6 +6956,9 @@ static void adapter_remove(struct btd_adapter *adapter)
+ g_slist_free(adapter->devices);
+ adapter->devices = NULL;
+
++ g_slist_free(adapter->load_keys);
++ adapter->load_keys = NULL;
++
+ discovery_cleanup(adapter, 0);
+
+ unload_drivers(adapter);