summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-05-24 10:59:51 +0200
committerDavid Seifert <soap@gentoo.org>2024-05-24 10:59:51 +0200
commit4cb73988356dd75b6f43951f9e84858bac7f947f (patch)
treec601f1c59d8d518c31d5506a63d7e3b24d3f8884 /sci-biology
parentsci-biology/samtools: add 1.20 (diff)
downloadgentoo-4cb73988356dd75b6f43951f9e84858bac7f947f.tar.gz
gentoo-4cb73988356dd75b6f43951f9e84858bac7f947f.tar.bz2
gentoo-4cb73988356dd75b6f43951f9e84858bac7f947f.zip
sci-biology/bcftools: add 1.20
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/bcftools/Manifest1
-rw-r--r--sci-biology/bcftools/bcftools-1.20.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/bcftools/Manifest b/sci-biology/bcftools/Manifest
index 3d2a9ade06aa..67e4996d956c 100644
--- a/sci-biology/bcftools/Manifest
+++ b/sci-biology/bcftools/Manifest
@@ -1 +1,2 @@
DIST bcftools-1.19.tar.bz2 7906216 BLAKE2B 43e7ac0fc6ffcf837607fb2fbbd58a72106a89b018d1fd4b24db0eb854a9bf0efd0c7762fae84bf7f51226346777be646d134159ea48e3eb3df71799e9353a3f SHA512 a203c65fa58fca8fb5276e73ed8fc23dfd841e9dc05881304a8b91327d60ac3b5fcf5a55a1f1bab5647037f037ff30f2881791052f6e29cf38c646cbc947a746
+DIST bcftools-1.20.tar.bz2 7883049 BLAKE2B 36bfd82c9500f384b75ef93242a5879123f7fd63c893c95a1ce5efbfa9396f2c1fd75025ea2dd48d37e7dc93426ffaffbb2f3c6bdf64128fbdd3af2a2f760b17 SHA512 c77294923a6bb5cb97a2c4947e79aa215612a62f71ba0e4dde627cd3d97ee9a28a3682e8ab2f3bedd0e75e2bb9800915d9430f9504f09ead4492d3583553db2a
diff --git a/sci-biology/bcftools/bcftools-1.20.ebuild b/sci-biology/bcftools/bcftools-1.20.ebuild
new file mode 100644
index 000000000000..27d474fe35f9
--- /dev/null
+++ b/sci-biology/bcftools/bcftools-1.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1
+
+DESCRIPTION="Utilities for variant calling and manipulating VCF and BCF files"
+HOMEPAGE="http://www.htslib.org"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-lang/perl
+ $(python_gen_cond_dep 'dev-python/matplotlib[${PYTHON_USEDEP}]')
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/zlib
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ default
+
+ python_fix_shebang misc/{gff2gff,guess-ploidy,plot-roh}.py
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --disable-bcftools-plugins \
+ --disable-libgsl \
+ --with-htslib=system
+}