summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch')
-rw-r--r--sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch84
1 files changed, 84 insertions, 0 deletions
diff --git a/sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch b/sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..63cbe2340008
--- /dev/null
+++ b/sci-chemistry/massxpert/files/massxpert-2.0.5-gentoo.patch
@@ -0,0 +1,84 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8085e0a..eaae8ce 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,10 +23,10 @@ SET (CMAKE_VERBOSE_MAKEFILE ON)
+
+ #############################################################
+ # Enable warnings and treat them as errors
+-SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall -Werror.")
++SET (PEDANTIC TRUE CACHE BOOL "Should we compile with -Wall.")
+
+ IF (PEDANTIC)
+- ADD_DEFINITIONS (-Wall -Werror)
++ ADD_DEFINITIONS (-Wall)
+ ENDIF (PEDANTIC)
+
+ #############################################################
+@@ -51,9 +51,9 @@ ENDIF (WIN32)
+ IF (UNIX AND NOT APPLE)
+ SET (MASSXPERT_BIN_DIR ${CMAKE_INSTALL_PREFIX}/bin)
+ SET (MASSXPERT_DATA_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert)
+- SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_PREFIX}/lib/massxpert/plugins)
++ SET (MASSXPERT_PLUGIN_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/massxpert/plugins)
+ SET (MASSXPERT_LOCALE_DIR ${CMAKE_INSTALL_PREFIX}/share/massxpert/locales)
+- SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert)
++ SET (MASSXPERT_DOC_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/massxpert-${VERSION})
+ SET (MASSXPERT_USERMAN_DIR ${MASSXPERT_DOC_DIR}/usermanual)
+ ENDIF (UNIX AND NOT APPLE)
+
+@@ -122,10 +122,6 @@ IF (${BUILD_PROGRAM})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The desktop file
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert.desktop
+@@ -165,10 +161,6 @@ IF (${BUILD_DATA})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (data)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-data.7
+@@ -201,10 +193,6 @@ IF (${BUILD_USERMANUAL})
+ ###############
+ # install stuff
+
+- # The license file
+- INSTALL (FILES COPYING
+- DESTINATION ${MASSXPERT_DOC_DIR})
+-
+ # The manual pages (user manual)
+ IF (UNIX AND NOT APPLE)
+ INSTALL (FILES massxpert-doc.7
+diff --git a/gui/configurationSettingsDlg.cpp b/gui/configurationSettingsDlg.cpp
+index bf595d5..82cad21 100644
+--- a/gui/configurationSettingsDlg.cpp
++++ b/gui/configurationSettingsDlg.cpp
+@@ -309,13 +309,11 @@ namespace massXpert
+ bool
+ ConfigurationSettingsDlg::checkLocalizationDir(const QDir &dir)
+ {
+- // At the moment there is the french translation: massxpert_fr.qm
++ // Gentoo provides optional installing of translations.
++ // If you decide not to have translations, then this check
++ // would fail.
+
+- QString filePath(dir.absolutePath() +
+- QDir::separator() +
+- "massxpert_fr.qm");
+-
+- return QFile::exists(filePath);
++ return true;
+ }
+
+