summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/raster3d/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/raster3d/files')
-rw-r--r--sci-chemistry/raster3d/files/2.9.1-as-needed.patch41
-rw-r--r--sci-chemistry/raster3d/files/3.0.2-as-needed.patch50
-rw-r--r--sci-chemistry/raster3d/files/3.0.2-gentoo-prefix.patch24
-rw-r--r--sci-chemistry/raster3d/files/raster3d-gcc-4.1-gentoo.patch74
4 files changed, 189 insertions, 0 deletions
diff --git a/sci-chemistry/raster3d/files/2.9.1-as-needed.patch b/sci-chemistry/raster3d/files/2.9.1-as-needed.patch
new file mode 100644
index 000000000000..2139804c8962
--- /dev/null
+++ b/sci-chemistry/raster3d/files/2.9.1-as-needed.patch
@@ -0,0 +1,41 @@
+diff --git a/Makefile b/Makefile
+index e75ffcf..bcdd05c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -188,7 +188,7 @@ avs2ps: avs2ps.c
+ $(CC) $(CFLAGS) $(FLAGS) $(LDFLAGS) -o avs2ps avs2ps.c -lm
+
+ balls: balls.f
+- $(FC) $(FFLAGS) -o balls balls.f
++ $(FC) $(LDFLAGS) $(FFLAGS) -o balls balls.f
+
+ local.o: Makefile.incl local.c
+ $(CC) $(CFLAGS) $(FLAGS) -c local.c
+@@ -201,21 +201,18 @@ ribbon: ribbon.f ribbon1.f modsubs.f
+ ribbon.f ribbon1.f modsubs.f -o ribbon
+
+ rastep: rastep.f quadric.o suv.o
+- $(FC) $(FFLAGS) \
+- rastep.f quadric.o suv.o $(LDFLAGS) \
+- -o rastep
++ $(FC) $(FFLAGS) $(LDFLAGS) -o rastep \
++ rastep.f quadric.o suv.o
+
+ render: render.o local.o quadric.o parse.o r3dtops.o ungz.o qinp.o
+- $(FC) $(FFLAGS) \
++ $(FC) $(FFLAGS) $(LDFLAGS) -o render \
+ render.o local.o quadric.o parse.o r3dtops.o ungz.o \
+ qinp.o \
+- $(LIBS) $(LDFLAGS) \
+- -o render
++ $(LIBS)
+
+ normal3d: normal3d.o quadric.o qinp.o ungz.o parameters.incl
+- $(FC) $(FFLAGS) \
+- normal3d.o quadric.o ungz.o qinp.o $(LDFLAGS) \
+- -o normal3d
++ $(FC) $(FFLAGS) $(LDFLAGS) -o normal3d \
++ normal3d.o quadric.o ungz.o qinp.o
+
+ stereo3d:
+
diff --git a/sci-chemistry/raster3d/files/3.0.2-as-needed.patch b/sci-chemistry/raster3d/files/3.0.2-as-needed.patch
new file mode 100644
index 000000000000..9e0961952535
--- /dev/null
+++ b/sci-chemistry/raster3d/files/3.0.2-as-needed.patch
@@ -0,0 +1,50 @@
+diff --git a/Makefile b/Makefile
+index 1a1c549..4d74dd0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -58,7 +58,7 @@ linux:
+ @echo OSDEFS = -DLINUX -DNETWORKBYTEORDER >> Makefile.incl
+ @echo include Makefile.package >> Makefile.incl
+ @echo >> Makefile.incl
+- @echo qinp.o: qinp.f >> Makefile.incl
++ @echo qinp.o: qinp.f normal3d.o render.o >> Makefile.incl
+ @echo " \$$(FC) -g -O0 -Wall -Wtabs -c -o qinp.o qinp.f" >> Makefile.incl
+ @echo >> Makefile.incl
+
+@@ -214,20 +214,20 @@ ribbon: ribbon.f ribbon1.f modsubs.f
+ ribbon.f ribbon1.f modsubs.f -o ribbon
+
+ rastep: rastep.f quadric.o suv.o
+- $(FC) $(FFLAGS) \
+- rastep.f quadric.o suv.o $(LDFLAGS) \
++ $(FC) $(FFLAGS) $(LDFLAGS) \
++ rastep.f quadric.o suv.o \
+ -o rastep
+
+ render: render.o local.o quadric.o parse.o r3dtogd.o ungz.o qinp.o
+- $(FC) $(FFLAGS) \
++ $(FC) $(FFLAGS) $(LDFLAGS) \
+ render.o local.o quadric.o parse.o r3dtogd.o ungz.o \
+ qinp.o \
+- $(LIBS) $(LDFLAGS) \
+- -o render
++ -o render \
++ $(LIBS)
+
+ normal3d: normal3d.o quadric.o qinp.o ungz.o parameters.incl
+- $(FC) $(FFLAGS) \
+- normal3d.o quadric.o ungz.o qinp.o $(LDFLAGS) \
++ $(FC) $(FFLAGS) $(LDFLAGS) \
++ normal3d.o quadric.o ungz.o qinp.o \
+ -o normal3d
+
+ stereo3d:
+@@ -264,7 +264,7 @@ example1.png: render_small
+ ./render_small
+
+ render_small: render_small.o local.o quadric.o parse_small.o r3dtogd.o ungz.o qinp_small.o
+- $(FC) $(FFLAGS) $^ $(LIBS) $(LDFLAGS) -o $@
++ $(FC) $(FFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ .SUFFIXES: .incl
+ SMALL=10
diff --git a/sci-chemistry/raster3d/files/3.0.2-gentoo-prefix.patch b/sci-chemistry/raster3d/files/3.0.2-gentoo-prefix.patch
new file mode 100644
index 000000000000..19b6cac3a6fe
--- /dev/null
+++ b/sci-chemistry/raster3d/files/3.0.2-gentoo-prefix.patch
@@ -0,0 +1,24 @@
+diff --git a/Makefile.template b/Makefile.template
+index 59de553..0ed283d 100644
+--- a/Makefile.template
++++ b/Makefile.template
+@@ -8,15 +8,15 @@ include VERSION
+ #
+ # Where to install the program, data files, and manuals
+ #
+-prefix = /usr/local
++prefix = @GENTOO_PORTAGE_EPREFIX@/usr/
+ bindir = $(prefix)/bin
+ datadir = $(prefix)/share/Raster3D/materials
+ mandir = $(prefix)/man/manl
+-htmldir = $(prefix)/share/Raster3D/html
++htmldir = $(prefix)/share/doc/MYPF/html
+ examdir = $(prefix)/share/Raster3D/examples
+
+-INCDIRS = -I/usr/include -I/usr/local/include
+-LIBDIRS = -L/usr/local/lib
++INCDIRS = -I@GENTOO_PORTAGE_EPREFIX@/usr/include
++LIBDIRS = -L@GENTOO_PORTAGE_EPREFIX@/usr/MYLIB
+
+ #
+ # TIFF support (enabled by default)
diff --git a/sci-chemistry/raster3d/files/raster3d-gcc-4.1-gentoo.patch b/sci-chemistry/raster3d/files/raster3d-gcc-4.1-gentoo.patch
new file mode 100644
index 000000000000..4525f5fdc8ba
--- /dev/null
+++ b/sci-chemistry/raster3d/files/raster3d-gcc-4.1-gentoo.patch
@@ -0,0 +1,74 @@
+diff -Naur Raster3D_2.7c/normal3d.f Raster3D_2.7c.new/normal3d.f
+--- Raster3D_2.7c/normal3d.f 2003-10-20 18:50:11.000000000 -0400
++++ Raster3D_2.7c.new/normal3d.f 2007-09-08 10:23:08.000000000 -0400
+@@ -443,7 +443,8 @@
+ READ (INPUT,'(A)',ERR=101) TITLE
+ IF (TITLE(1:1).EQ.'#') GOTO 100
+ GOTO 102
+- 101 WRITE (NOISE,'(A,A)') ' >> Cannot open or read file ',TITLE(2:132)
++ 101 WRITE (NOISE,'(A,A)') ' >> Cannot open or read file ',
++ * TITLE(2:132)
+ CALL EXIT(-1)
+ 102 CONTINUE
+ ENDIF
+diff -Naur Raster3D_2.7c/parse.f Raster3D_2.7c.new/parse.f
+--- Raster3D_2.7c/parse.f 2003-10-20 18:50:11.000000000 -0400
++++ Raster3D_2.7c.new/parse.f 2007-09-08 10:23:48.000000000 -0400
+@@ -4,7 +4,8 @@
+ COMMON /OPTIONS/ FONTSCALE, GAMMA, ZOOM, NSCHEME, SHADOWFLAG, XBG,
+ & NAX, NAY, OTMODE, QUALITY, INVERT, LFLAG
+ REAL FONTSCALE, GAMMA, ZOOM
+- INTEGER NSCHEME, SHADOWFLAG, XBG
++ INTEGER NSCHEME, SHADOWFLAG
++ INTEGER*8 XBG
+ INTEGER*2 NAX, NAY, OTMODE, QUALITY
+ LOGICAL*2 INVERT, LFLAG
+ c
+diff -Naur Raster3D_2.7c/rastep.f Raster3D_2.7c.new/rastep.f
+--- Raster3D_2.7c/rastep.f 2004-02-12 12:01:31.000000000 -0500
++++ Raster3D_2.7c.new/rastep.f 2007-09-08 10:23:08.000000000 -0400
+@@ -133,7 +133,7 @@
+ c
+ c Support for validation of similarity of bonded atoms
+ logical suvflag
+- integer suvlun, suvbad
++ integer suvlun, suvbad, defcols
+ real anisov(6)
+ c
+ c Default to CPK colors and VDW radii
+diff -Naur Raster3D_2.7c/render.f Raster3D_2.7c.new/render.f
+--- Raster3D_2.7c/render.f 2003-10-20 18:50:11.000000000 -0400
++++ Raster3D_2.7c.new/render.f 2007-09-08 10:23:08.000000000 -0400
+@@ -792,9 +792,9 @@
+ * Get background colour
+ READ (INPUT,*,ERR=104) BKGND
+ if (XBG.NE.0) then
+- BKGND(3) = FLOAT(iand(XBG,'00FF'X)) / 255.
+- BKGND(2) = FLOAT(iand(XBG,'FF00'X)/256) / 255.
+- BKGND(1) = FLOAT(iand(XBG,'FF0000'X)/65536) / 255.
++ BKGND(3) = REAL(iand(XBG,'00FF'X)) / 255.
++ BKGND(2) = REAL(iand(XBG,'FF00'X)/256) / 255.
++ BKGND(1) = REAL(iand(XBG,'FF0000'X)/65536) / 255.
+ BKGND(3) = BKGND(3)**2
+ BKGND(2) = BKGND(2)**2
+ BKGND(1) = BKGND(1)**2
+@@ -3679,7 +3679,7 @@
+ FRAC = DETAIL(K+8)
+ INEXT = INDTOP + 1
+ IF (TYPE(INEXT).EQ.VERTEXRGB) INEXT = INEXT + 1
+- CALL ASSERT(TYPE(INEXT).EQ.VERTRANSP,'lost vertex transp')
++ CALL ASSERT(TYPE(INEXT).EQ.VERTRANSP,'lost vertex transp')
+ K = LIST(INEXT)
+ CLRITY = FRAC*DETAIL(K+1) + (1.-FRAC)*DETAIL(K+2)
+ ELSE IF (TYPE(INDTOP).EQ.TRIANG) THEN
+diff -Naur Raster3D_2.7c/rings3d.f Raster3D_2.7c.new/rings3d.f
+--- Raster3D_2.7c/rings3d.f 2003-10-20 18:50:11.000000000 -0400
++++ Raster3D_2.7c.new/rings3d.f 2007-09-08 10:23:08.000000000 -0400
+@@ -16,7 +16,6 @@
+ integer input, output, noise
+ parameter (input=5, output=6, noise=0)
+ integer iargc, narg
+- external iargc
+ character*64 options
+ logical bflag, pflag, sflag
+ c