summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:52:11 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:11 +0100
commit4e96de47de18a7b6e7ef6d897da17f15103914b0 (patch)
tree1a0edaf08f6d3dad01af3e18a8e5403da481a710 /sci-chemistry/wxmacmolplt
parentsci-chemistry/easychem: clean up patches (diff)
downloadgentoo-4e96de47de18a7b6e7ef6d897da17f15103914b0.tar.gz
gentoo-4e96de47de18a7b6e7ef6d897da17f15103914b0.tar.bz2
gentoo-4e96de47de18a7b6e7ef6d897da17f15103914b0.zip
sci-chemistry/wxmacmolplt: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-chemistry/wxmacmolplt')
-rw-r--r--sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch7
-rw-r--r--sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild4
2 files changed, 6 insertions, 5 deletions
diff --git a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch
index 08986db5bff2..809d7723cbb0 100644
--- a/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch
+++ b/sci-chemistry/wxmacmolplt/files/wxmacmolplt-7.5-glew.patch
@@ -1,12 +1,11 @@
-diff -urN wxmacmolplt-7.4.2.orig/configure.ac wxmacmolplt-7.4.2/configure.ac
---- wxmacmolplt-7.4.2.orig/configure.ac 2010-12-05 02:48:29.000000000 +0300
-+++ wxmacmolplt-7.4.2/configure.ac 2010-12-06 19:30:24.000000000 +0300
+--- a/configure.ac
++++ b/configure.ac
@@ -20,7 +20,7 @@
;;
*)
HOST=LINUX
- LIBGL="-lGL -lGLU"
-+ LIBGL=`pkg-config --libs glu glew`
++ LIBGL=`${PKG_CONFIG} --libs glu glew`
;;
esac
AM_CONDITIONAL(HOST_IS_MSW, [test "x$HOST" == xMSW])
diff --git a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
index 5a5d68427ca7..d100dad51cbc 100644
--- a/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
+++ b/sci-chemistry/wxmacmolplt/wxmacmolplt-7.5-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
WX_GTK_VER=3.0
-inherit autotools desktop wxwidgets
+inherit autotools desktop toolchain-funcs wxwidgets
DESCRIPTION="Chemical 3D graphics program with GAMESS input builder"
HOMEPAGE="http://www.scl.ameslab.gov/MacMolPlt/"
@@ -32,6 +32,8 @@ src_prepare() {
}
src_configure() {
+ tc-export PKG_CONFIG
+
setup-wxwidgets unicode
econf \
--with-glew \