summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2024-08-18 13:28:08 -0700
committerYixun Lan <dlan@gentoo.org>2024-08-22 11:40:14 +0000
commit33b38759843a2ed2d82d7242f254bb5746631dcf (patch)
tree836906f00199166aa1102520785affc01a3235db /sci-electronics
parentsci-electronics/kicad: Fix setup-wxwidgets call site (diff)
downloadgentoo-33b38759843a2ed2d82d7242f254bb5746631dcf.tar.gz
gentoo-33b38759843a2ed2d82d7242f254bb5746631dcf.tar.bz2
gentoo-33b38759843a2ed2d82d7242f254bb5746631dcf.zip
sci-electronics/kicad: add 8.0.4
Additionally enable pcbnew tests as they work now, as well as add ebuild fix for setup-wxwidgets. Bug: https://bugs.gentoo.org/937351 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad/Manifest1
-rw-r--r--sci-electronics/kicad/kicad-8.0.4.ebuild188
2 files changed, 189 insertions, 0 deletions
diff --git a/sci-electronics/kicad/Manifest b/sci-electronics/kicad/Manifest
index 408edc5dd6f3..5b1fad841a20 100644
--- a/sci-electronics/kicad/Manifest
+++ b/sci-electronics/kicad/Manifest
@@ -1,3 +1,4 @@
DIST kicad-7.0.10.tar.bz2 43991960 BLAKE2B 3e21f575e41a6036ff2a9c3ab17472e51c73612ddadbf88631717b43024e604a8607fff013828823ff4db4d4263ac8e3bcc3b069e3efdfdc66fdb627f60f192a SHA512 f8005e6cb685c4cdc3982eec644f6d4a115138eaa19ca0bd2e6ae07613eac9c98fd7cdc181dd83e6c6d3c4b73ff6a54261ac5448a2a9c53298bc611c1bf408e1
DIST kicad-7.0.11.tar.bz2 44083805 BLAKE2B d923581f49b3cf48776de56ba12ddc99e942269c0c14950bb6b3413fb616af74a1b4e7095fc746e20125096f7d2e4c7a9f271dd58918b22fa53e8ce7b78fa6f6 SHA512 28d5560ead989dcfb6d3b07e37443de3bf1883bd56604ae20f70c0a068504fd8745f7011507d417f487b86071cec130ac8eb7bda7513d096e78dcc3dc98585aa
DIST kicad-8.0.3.tar.bz2 72936035 BLAKE2B 667d6bc2e3a3f7ccc7a22a63d22702e6886404a86bca6ca2acdd5181c7046995332bb70f1fca9d25b20d9a7e1a9545488d00fb8d2ca70fd479a989ccea6c856f SHA512 14921827120381e749d094d2a76c850d2bee394c496859df3f4550a32b678a9523199a745e199f7c874ef85b2e8279129578e666c16932fbbcb1ba98c4e62b34
+DIST kicad-8.0.4.tar.bz2 72958676 BLAKE2B 756970ea920e8951d76a53596b46ca83b904e50f50474f03b2efa1aad815092c819b5ad144717bfeba7c778cd3fd18fc2f082beaf47e88a51f9acc575e8aaac2 SHA512 b490cd201b79388ca9ba771363043373034f036cc73e520cf1c4cf9c011dfd25a5e9c3eee8a7bfe23521193cd44f6c28aaf3e270e8444e7ba75dff62e6a74f1e
diff --git a/sci-electronics/kicad/kicad-8.0.4.ebuild b/sci-electronics/kicad/kicad-8.0.4.ebuild
new file mode 100644
index 000000000000..4cbb09a09b4b
--- /dev/null
+++ b/sci-electronics/kicad/kicad-8.0.4.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+WX_GTK_VER="3.2-gtk3"
+
+inherit check-reqs cmake flag-o-matic optfeature python-single-r1 toolchain-funcs wxwidgets xdg-utils
+
+DESCRIPTION="Electronic Schematic and PCB design tools"
+HOMEPAGE="https://www.kicad.org"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/code/kicad.git"
+ inherit git-r3
+else
+ MY_PV="${PV/_rc/-rc}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://gitlab.com/kicad/code/${PN}/-/archive/${MY_PV}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+
+ if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+ fi
+fi
+
+# BSD for bundled pybind
+LICENSE="GPL-2+ GPL-3+ Boost-1.0 BSD"
+SLOT="0"
+IUSE="doc examples nls openmp test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+# Contains bundled pybind but it's patched for wx
+# See https://gitlab.com/kicad/code/kicad/-/commit/74e4370a9b146b21883d6a2d1df46c7a10bd0424
+# Depend on opencascade:0 to get unslotted variant (so we know path to it), bug #833301
+# Depend wxGTK version needs to be limited due to switch from EGL to GLX, bug #911120
+COMMON_DEPEND="
+ app-crypt/libsecret
+ dev-db/unixODBC
+ dev-libs/boost:=[context,nls]
+ dev-libs/libgit2:=
+ media-libs/freeglut
+ media-libs/glew:0=
+ >=media-libs/glm-0.9.9.1
+ media-libs/mesa[X(+)]
+ net-misc/curl
+ >=sci-libs/opencascade-7.5.0:0=
+ >=x11-libs/cairo-1.8.8:=
+ >=x11-libs/pixman-0.30
+ >sci-electronics/ngspice-27[shared]
+ sys-libs/zlib
+ >=x11-libs/wxGTK-3.2.2.1-r3:${WX_GTK_VER}[X,opengl]
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[context,nls,python,${PYTHON_USEDEP}]
+ >=dev-python/wxpython-4.2.0:*[${PYTHON_USEDEP}]
+ ')
+ ${PYTHON_DEPS}
+ nls? (
+ sys-devel/gettext
+ )
+ test? (
+ media-gfx/cairosvg
+ )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sci-electronics/electronics-menu
+"
+BDEPEND=">=dev-lang/swig-4.0
+ doc? ( app-text/doxygen )"
+
+if [[ ${PV} == 9999 ]] ; then
+ # x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi
+
+CHECKREQS_DISK_BUILD="1500M"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.0.3-gcc15-cstdint.patch
+)
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+
+ python-single-r1_pkg_setup
+ check-reqs_pkg_setup
+}
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ else
+ default_src_unpack
+ fi
+}
+
+src_prepare() {
+ filter-lto # Bug 927482
+ cmake_src_prepare
+}
+
+src_configure() {
+ xdg_environment_reset
+
+ local mycmakeargs=(
+ -DKICAD_DOCS="${EPREFIX}/usr/share/doc/${PN}-doc-${PV}"
+
+ -DKICAD_SCRIPTING_WXPYTHON=ON
+ -DKICAD_USE_EGL=OFF
+
+ -DKICAD_BUILD_I18N="$(usex nls)"
+ -DKICAD_I18N_UNIX_STRICT_PATH="$(usex nls)"
+
+ -DPYTHON_DEST="$(python_get_sitedir)"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+
+ -DKICAD_INSTALL_DEMOS="$(usex examples)"
+ -DCMAKE_SKIP_RPATH="ON"
+
+ -DOCC_INCLUDE_DIR="${CASROOT}"/include/opencascade
+ -DOCC_LIBRARY_DIR="${CASROOT}"/$(get_libdir)/opencascade
+
+ -DKICAD_SPICE_QA="$(usex test)"
+ -DKICAD_BUILD_QA_TESTS="$(usex test)"
+ )
+
+ setup-wxwidgets
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cmake_src_compile doxygen-docs
+ fi
+}
+
+src_test() {
+ # Test cannot find library in Portage's sandbox. Let's create a link so test can run.
+ mkdir -p "${BUILD_DIR}/qa/eeschema/" || die
+ ln -s "${BUILD_DIR}/eeschema/_eeschema.kiface" "${BUILD_DIR}/qa/eeschema/_eeschema.kiface" || die
+
+ export CMAKE_SKIP_TESTS=(
+ qa_cli
+ )
+
+ # LD_LIBRARY_PATH is there to help it pick up the just-built libraries
+ LD_LIBRARY_PATH="${BUILD_DIR}/common:${BUILD_DIR}/common/gal:${BUILD_DIR}/3d-viewer/3d_cache/sg:${LD_LIBRARY_PATH}" \
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+
+ dodoc doxygen/eagle-plugin-notes.txt
+
+ if use doc ; then
+ cd doxygen || die
+ dodoc -r out/html/.
+ fi
+}
+
+pkg_postinst() {
+ optfeature "Component symbols library" sci-electronics/kicad-symbols
+ optfeature "Component footprints library" sci-electronics/kicad-footprints
+ optfeature "3D models of components " sci-electronics/kicad-packages3d
+ optfeature "Project templates" sci-electronics/kicad-templates
+ optfeature "Extended documentation" app-doc/kicad-doc
+ optfeature "Creating 3D models of components" media-gfx/wings
+
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+}